# CVE-2026-114111: Sharp before 0.35.5 RCE via librsvg Dependency Memory Vulnerability


- **Severity:** High 8.9 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** CLEANSTART-2026-AN86015, CLEANSTART-2026-BZ86310, CLEANSTART-2026-JE80726, CLSA-2026-1791887358, ECHO-6169-5cd8-c8e3, GHSA-j56w-ppx9-7qff, GHSA-wq5f-xc86-pv6w, MINI-7hf2-g4mw-2mxq, MINI-865q-gv9h-3385, MINI-cv98-hf8c-c96m, MINI-cxrm-7w47-gmjh, MINI-gg74-wqhc-5v6q, MINI-p73g-gjff-2723, ROOT-APP-NPM-GHSA-wq5f-xc86-pv6w

## What is CVE-2026-114111?

CVE-2026-114111 is a high-severity vulnerability in lovell sharp, published on 21 Oct 2026. 

### Official description

sharp before 0.35.5 bundles a librsvg dependency affected by a memory-related vulnerability (CVE-2026-96889) that, under certain runtime-specific conditions, can lead to code execution on glibc-based Linux. An attacker can supply a crafted SVG image that, when decoded by sharp through librsvg, may result in arbitrary code execution.

Weakness: CWE-416 (Use After Free)

## Which versions are affected by CVE-2026-114111?

2 open source packages ship an affected version, including sharp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sharp` | npm | All versions | 0.35.5 |
| `sharp` | npm | All versions | 0.35.5 |

## How do I fix CVE-2026-114111?

Upgrade sharp to 0.35.5 or later.

## Is CVE-2026-114111 being exploited?

There is no known exploitation of CVE-2026-114111 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114111 and fix it if it is affected.

What it is: CVE-2026-114111 is a high-severity vulnerability in lovell sharp, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114111 in the wild and no public exploit code.

Affected packages and fixed versions:
- sharp (npm): affected all versions; fixed in 0.35.5
- sharp (npm): affected all versions; fixed in 0.35.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114111/ (Markdown: https://insights.sbomify.com/CVE-2026-114111/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114111
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114111
- OSV: https://osv.dev/vulnerability/CVE-2026-114111

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114111/
Summaries are generated and may contain mistakes; the official description above is the record.
