# CVE-2026-114112: Sharp before 0.35.4 RCE via bundled libheif AVIF decoding


- **Severity:** High 8.9 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 22 Oct 2026
- **Also known as:** CLEANSTART-2026-SX69488, CLEANSTART-2026-UG53447, ECHO-2762-76fb-9bb0, GHSA-gqw3-74gm-648q, GHSA-rgj7-g3m4-5g8c, MINI-53hj-pj4j-3x3h, MINI-f53w-g5cg-fwv6, MINI-jww4-9j57-96v9, MINI-p84r-4j28-39qh, MINI-q4jh-xqm6-78r8, MINI-w39h-8frc-x8m5, ROOT-APP-NPM-GHSA-rgj7-g3m4-5g8c

## What is CVE-2026-114112?

CVE-2026-114112 is a high-severity vulnerability in lovell sharp, published on 21 Oct 2026. 

### Official description

Sharp before 0.35.4 bundles a vulnerable libheif dependency that allows attackers to achieve possible remote code execution on glibc-based Linux by supplying crafted images. Attackers can submit malicious AVIF/HEIF input to applications processing untrusted images with sharp, triggering libheif decoding flaws to execute code.

Weakness: CWE-122 (Heap-based Buffer Overflow)

## Which versions are affected by CVE-2026-114112?

2 open source packages ship an affected version, including sharp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sharp` | npm | All versions | 0.35.4 |
| `sharp` | npm | All versions | 0.35.4 |

## How do I fix CVE-2026-114112?

Upgrade sharp to 0.35.4 or later.

## Is CVE-2026-114112 being exploited?

There is no known exploitation of CVE-2026-114112 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114112 and fix it if it is affected.

What it is: CVE-2026-114112 is a high-severity vulnerability in lovell sharp, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114112 in the wild and no public exploit code.

Affected packages and fixed versions:
- sharp (npm): affected all versions; fixed in 0.35.4
- sharp (npm): affected all versions; fixed in 0.35.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114112/ (Markdown: https://insights.sbomify.com/CVE-2026-114112/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114112
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114112
- OSV: https://osv.dev/vulnerability/CVE-2026-114112

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114112/
Summaries are generated and may contain mistakes; the official description above is the record.
