# CVE-2026-114113: Sharp before 0.35.0 Multiple Vulnerabilities via Bundled libvips Image Decoders


- **Severity:** High 8.4 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:N/VC:L/VI:H/VA:H/SC:L/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 27 Oct 2026
- **Also known as:** CLEANSTART-2026-BO31904, CLEANSTART-2026-TS09001, CLEANSTART-2026-WQ72768, ECHO-596c-e319-c555, GHSA-7vv3-w8cj-2245, GHSA-f88m-g3jw-g9cj, MINI-8h75-9j37-v5w3, MINI-h2w5-37w5-q6v2, MINI-j87h-cq22-q62w, MINI-wh9f-4p4p-vff7, MINI-x8hm-84g7-c75j, ROOT-APP-NPM-GHSA-f88m-g3jw-g9cj

## What is CVE-2026-114113?

CVE-2026-114113 is a high-severity vulnerability in lovell sharp, published on 21 Oct 2026. 

### Official description

Sharp before 0.35.0 bundles a version of libvips affected by multiple vulnerabilities (CVE-2026-33327, CVE-2026-33328, CVE-2026-35590, CVE-2026-35591 and CVE-2026-69242) in its GIF, TIFF and VIPS image decoders. Attackers can supply crafted GIF, TIFF or VIPS files to applications using sharp to process untrusted input, triggering these libvips flaws.

Weakness: CWE-1395 (Dependency on Vulnerable Third-Party Component)

## Which versions are affected by CVE-2026-114113?

2 open source packages ship an affected version, including sharp.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `sharp` | npm | All versions | 0.35.0 |
| `sharp` | npm | All versions | 0.35.0 |

## How do I fix CVE-2026-114113?

Upgrade sharp to 0.35.0 or later.

## Is CVE-2026-114113 being exploited?

There is no known exploitation of CVE-2026-114113 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114113 and fix it if it is affected.

What it is: CVE-2026-114113 is a high-severity vulnerability in lovell sharp, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114113 in the wild and no public exploit code.

Affected packages and fixed versions:
- sharp (npm): affected all versions; fixed in 0.35.0
- sharp (npm): affected all versions; fixed in 0.35.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114113/ (Markdown: https://insights.sbomify.com/CVE-2026-114113/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114113
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114113
- OSV: https://osv.dev/vulnerability/CVE-2026-114113

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114113/
Summaries are generated and may contain mistakes; the official description above is the record.
