# CVE-2026-114127: Astro: Arbitrary CSS injection in Astro View Transitions


- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:P/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** GHSA-mpr7-6m5w-76rw

## What is CVE-2026-114127?

CVE-2026-114127 is a low-severity vulnerability in withastro astro, published on 21 Oct 2026. 

### Official description

Astro is a web framework for content-driven websites. From 7.1.0 until 7.3.3, Astro's server-side View Transition CSS generator does not keep string animation properties within their generated declarations. An application that passes attacker-controlled data into properties such as duration, delay, easing, direction, fillMode, or animation names can allow CSS delimiters to terminate the declaration and add attacker-selected rules to the server-rendered page. The generated stylesheet still escapes literal less-than characters, so the injected content cannot terminate the style element or directly inject HTML or JavaScript. The injected CSS can conceal or reposition content, add generated text, and otherwise misrepresent the interface; some applications may also expose data already present in selectable DOM attributes through conditional resource loads. This issue is fixed in 7.3.3.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-114127?

2 open source packages ship an affected version, including astro.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `astro` | npm | From 7.1.0 | 7.3.3 |
| `astro` | npm | From 7.1.0 | 7.3.3 |

## How do I fix CVE-2026-114127?

Upgrade astro to 7.3.3 or later.

## Is CVE-2026-114127 being exploited?

There is no known exploitation of CVE-2026-114127 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114127 and fix it if it is affected.

What it is: CVE-2026-114127 is a low-severity vulnerability in withastro astro, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114127 in the wild and no public exploit code.

Affected packages and fixed versions:
- astro (npm): affected from 7.1.0; fixed in 7.3.3
- astro (npm): affected from 7.1.0; fixed in 7.3.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114127/ (Markdown: https://insights.sbomify.com/CVE-2026-114127/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114127
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114127
- OSV: https://osv.dev/vulnerability/CVE-2026-114127

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114127/
Summaries are generated and may contain mistakes; the official description above is the record.
