# CVE-2026-114133: Nuxt server islands render `useHeadSafe` input without sanitisation


- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-xfq5-w38q-pc2x

## What is CVE-2026-114133?

CVE-2026-114133 is a medium-severity vulnerability in nuxt, published on 21 Oct 2026. 

### Official description

Nuxt is an open-source web development framework for Vue.js. From 3.13.0 until 4.6.2, the server-island renderer serializes raw useHeadSafe entry input into the island response without preserving the safe-input marker, and NuxtIsland later inserts that input into the page head as an ordinary entry. An application that passes attacker-controlled data to useHeadSafe in a .server.vue component or page, or in a component rendered through NuxtIsland, can therefore render values normally removed by the allowlist, including event-handler attributes or executable script content, resulting in stored cross-site scripting in the application origin. This issue is fixed in version 4.6.2 .

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-114133?

2 open source packages ship an affected version, including nuxt.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nuxt` | npm | From 3.13.0 | 4.6.2 |
| `nuxt` | npm | From 3.13.0 | 4.6.2 |

## How do I fix CVE-2026-114133?

Upgrade nuxt to 4.6.2 or later.

## Is CVE-2026-114133 being exploited?

There is no known exploitation of CVE-2026-114133 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114133 and fix it if it is affected.

What it is: CVE-2026-114133 is a medium-severity vulnerability in nuxt, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114133 in the wild and no public exploit code.

Affected packages and fixed versions:
- nuxt (npm): affected from 3.13.0; fixed in 4.6.2
- nuxt (npm): affected from 3.13.0; fixed in 4.6.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114133/ (Markdown: https://insights.sbomify.com/CVE-2026-114133/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114133
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114133
- OSV: https://osv.dev/vulnerability/CVE-2026-114133

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114133/
Summaries are generated and may contain mistakes; the official description above is the record.
