# CVE-2026-114135: Jupyter Server: Gateway WebSocket handler bypasses kernel execute authorization


- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-114135, GHSA-354v-3q48-cv69, UBUNTU-CVE-2026-114135

## What is CVE-2026-114135?

CVE-2026-114135 is a high-severity vulnerability in jupyter-server jupyter_server, published on 21 Oct 2026. 

### Official description

Jupyter Server is the backend for Jupyter web applications. From 2.0.0 until 2.6.0, enabling GatewayClient.url replaced the normal KernelWebsocketHandler with WebSocketChannelsHandler, which authenticated the user but did not call authorizer.is_authorized(...) for the execute action on the kernels resource. A restricted authenticated user could therefore open an upstream kernel channel and obtain kernel execution despite the configured Authorizer denying that action, exposing data and credentials available to the kernel and permitting modification or disruption of the kernel environment. The default gateway configuration is fixed in version 2.6.0. In 2.6.0 and later, the same authorization bypass remains possible when a deployment manually registers the deprecated jupyter_server.gateway.handlers module, because its handler still omits the configured kernel-execute authorization decision.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-114135?

2 open source packages ship an affected version, including jupyter-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `jupyter-server` | PyPI | From 2.0.0 | 2.6.0 |
| `jupyter-server` | PyPI | From 2.0.0 | 2.6.0 |

## How do I fix CVE-2026-114135?

Upgrade jupyter-server to 2.6.0 or later.

## Is CVE-2026-114135 being exploited?

There is no known exploitation of CVE-2026-114135 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114135 and fix it if it is affected.

What it is: CVE-2026-114135 is a high-severity vulnerability in jupyter-server jupyter_server, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114135 in the wild and no public exploit code.

Affected packages and fixed versions:
- jupyter-server (PyPI): affected from 2.0.0; fixed in 2.6.0
- jupyter-server (PyPI): affected from 2.0.0; fixed in 2.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114135/ (Markdown: https://insights.sbomify.com/CVE-2026-114135/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114135
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114135
- OSV: https://osv.dev/vulnerability/CVE-2026-114135

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114135/
Summaries are generated and may contain mistakes; the official description above is the record.
