# CVE-2026-114136: Django REST framework: JSONParser applies an attacker-named codec to the request stream


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-114136, ECHO-a271-2dee-e99c, GHSA-3547-9m27-7rxg, ROOT-APP-PYPI-CVE-2026-114136, UBUNTU-CVE-2026-114136

## What is CVE-2026-114136?

CVE-2026-114136 is a high-severity vulnerability in encode django-rest-framework, published on 21 Oct 2026. 

### Official description

Django REST framework is a toolkit for building Web APIs. From 3.6.4 until 3.18.2, JSONParser.parse in rest_framework/parsers.py uses the client-supplied Content-Type charset value with codecs.getreader, which accepts byte-transform codecs such as bz2_codec rather than only text encodings. A remote unauthenticated client can therefore cause a compressed JSON request body to be expanded after Django has enforced DATA_UPLOAD_MAX_MEMORY_SIZE against only the wire bytes, allowing a very small request to consume substantial per-worker memory. The default parser set is sufficient, and any reachable endpoint that accepts a JSON body is affected. This issue is fixed in version 3.18.2.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-409 (Improper Handling of Highly Compressed Data (Data Amplification))

## Which versions are affected by CVE-2026-114136?

2 open source packages ship an affected version, including djangorestframework.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `djangorestframework` | PyPI | From 3.6.4 | 3.18.2 |
| `djangorestframework` | PyPI | From 3.6.4 | 3.18.2 |

## How do I fix CVE-2026-114136?

Upgrade djangorestframework to 3.18.2 or later.

## Is CVE-2026-114136 being exploited?

There is no known exploitation of CVE-2026-114136 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114136 and fix it if it is affected.

What it is: CVE-2026-114136 is a high-severity vulnerability in encode django-rest-framework, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114136 in the wild and no public exploit code.

Affected packages and fixed versions:
- djangorestframework (PyPI): affected from 3.6.4; fixed in 3.18.2
- djangorestframework (PyPI): affected from 3.6.4; fixed in 3.18.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114136/ (Markdown: https://insights.sbomify.com/CVE-2026-114136/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114136
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114136
- OSV: https://osv.dev/vulnerability/CVE-2026-114136

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114136/
Summaries are generated and may contain mistakes; the official description above is the record.
