# CVE-2026-114140: nbconvert: File write via path traversal in cell output filenames


- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-114140, GHSA-pjvx-prjx-h659, UBUNTU-CVE-2026-114140

## What is CVE-2026-114140?

CVE-2026-114140 is a high-severity vulnerability in jupyter nbconvert, published on 21 Oct 2026. 

### Official description

The nbconvert tool, jupyter nbconvert, converts Jupyter notebooks to various other formats via Jinja templates. From 5.4.0 until 7.17.2, ExtractOutputPreprocessor in nbconvert/preprocessors/extractoutput.py joins the attacker-controlled cell output metadata filename to output_files_dir without limiting the result to the intended directory. When a victim converts a malicious notebook with the markdown, LaTeX, reStructuredText, or AsciiDoc exporter, path traversal in the output filename can write attacker-controlled output data to arbitrary locations accessible to the victim. Running the notebook cell again replaces the malicious output metadata, but merely converting the supplied notebook does not. This issue is fixed in version 7.17.2.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-114140?

2 open source packages ship an affected version, including nbconvert.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nbconvert` | PyPI | From 5.4.0 | 7.17.2 |
| `nbconvert` | PyPI | From 5.4.0 | 7.17.2 |

## How do I fix CVE-2026-114140?

Upgrade nbconvert to 7.17.2 or later.

## Is CVE-2026-114140 being exploited?

There is no known exploitation of CVE-2026-114140 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114140 and fix it if it is affected.

What it is: CVE-2026-114140 is a high-severity vulnerability in jupyter nbconvert, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114140 in the wild and no public exploit code.

Affected packages and fixed versions:
- nbconvert (PyPI): affected from 5.4.0; fixed in 7.17.2
- nbconvert (PyPI): affected from 5.4.0; fixed in 7.17.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114140/ (Markdown: https://insights.sbomify.com/CVE-2026-114140/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114140
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114140
- OSV: https://osv.dev/vulnerability/CVE-2026-114140

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114140/
Summaries are generated and may contain mistakes; the official description above is the record.
