# CVE-2026-114141: toml-node: Quadratic-complexity DoS via many array-of-tables headers in toml.parse()


- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** GHSA-4qx8-w7c3-pj3p, ROOT-APP-NPM-CVE-2026-114141

## What is CVE-2026-114141?

CVE-2026-114141 is a high-severity vulnerability in BinaryMuse toml-node, published on 21 Oct 2026. 

### Official description

toml-node is a TOML parser for Node.js and the browser. Prior to 5.0.1, the toml.parse() compiler's addTableArray() function in lib/compiler.js rescans the complete assignedPaths and valueAssignments bookkeeping sets for every array-of-tables header. Distinct [[name]] paths are not pruned, so a document with many such headers causes quadratic synchronous work and can block the Node.js event loop, denying service to other operations in the process. This issue is fixed in version 5.0.1.

Weakness: CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2026-114141?

2 open source packages ship an affected version, including toml.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `toml` | npm | All versions | 5.0.1 |
| `toml` | npm | All versions | 5.0.1 |

## How do I fix CVE-2026-114141?

Upgrade toml to 5.0.1 or later.

## Is CVE-2026-114141 being exploited?

There is no known exploitation of CVE-2026-114141 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114141 and fix it if it is affected.

What it is: CVE-2026-114141 is a high-severity vulnerability in BinaryMuse toml-node, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114141 in the wild and no public exploit code.

Affected packages and fixed versions:
- toml (npm): affected all versions; fixed in 5.0.1
- toml (npm): affected all versions; fixed in 5.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114141/ (Markdown: https://insights.sbomify.com/CVE-2026-114141/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114141
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114141
- OSV: https://osv.dev/vulnerability/CVE-2026-114141

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114141/
Summaries are generated and may contain mistakes; the official description above is the record.
