# CVE-2026-114145: GitPython validates a submodule's ".git" path only after cloning into it (RCE)


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** CLSA-2026-1792741260, DEBIAN-CVE-2026-114145, ECHO-5e70-37df-b83d, GHSA-83vg-56qc-22m7, MINI-qvx6-jjgm-mqm5, UBUNTU-CVE-2026-114145

## What is CVE-2026-114145?

CVE-2026-114145 is a high-severity vulnerability in gitpython-developers GitPython, published on 21 Oct 2026. 

### Official description

GitPython is a python library used to interact with Git repositories. Prior to 3.2.1, create_submodule() in git/objects/submodule/base.py accepts an attacker-influenced submodule path such as .git/hooks and invokes _clone_repo() before safely rejecting the destination. In 3.1.x, _validate_repo_path() does not exist and the call succeeds silently, while in 3.2.0 and later affected revisions the check in git/index/base.py raises ValueError only after the clone has written to disk and does not remove the planted file. An attacker-controlled submodule can therefore place an executable post-checkout hook that a later Git operation executes. Exploitation requires an application to accept an untrusted submodule path and a clone destination such as .git/hooks that is empty enough for Git to clone into it, which commonly means that default sample hooks are absent. This issue is fixed in version 3.2.1.

Weakness: CWE-696 (Incorrect Behavior Order)

## Which versions are affected by CVE-2026-114145?

2 open source packages ship an affected version, including Gitpython and gitpython.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Gitpython` | PyPI | All versions | 3.2.1 |
| `gitpython` | PyPI | All versions | 3.2.1 |

## How do I fix CVE-2026-114145?

Upgrade Gitpython to 3.2.1 or later.

## Is CVE-2026-114145 being exploited?

There is no known exploitation of CVE-2026-114145 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114145 and fix it if it is affected.

What it is: CVE-2026-114145 is a high-severity vulnerability in gitpython-developers GitPython, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114145 in the wild and no public exploit code.

Affected packages and fixed versions:
- Gitpython (PyPI): affected all versions; fixed in 3.2.1
- gitpython (PyPI): affected all versions; fixed in 3.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114145/ (Markdown: https://insights.sbomify.com/CVE-2026-114145/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114145
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114145
- OSV: https://osv.dev/vulnerability/CVE-2026-114145

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114145/
Summaries are generated and may contain mistakes; the official description above is the record.
