# CVE-2026-114214: Incorrect Authorization vulnerability in ash-project ash allows a client to read destination records unrelated to the source record through


- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 25 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** EEF-CVE-2026-114214, GHSA-g2h4-xp57-q863

## What is CVE-2026-114214?

CVE-2026-114214 is a medium-severity vulnerability in ash-project ash, published on 25 Oct 2026. 

### Official description

Incorrect Authorization vulnerability in ash-project ash allows a client to read destination records unrelated to the source record through a through relationship.

When a has_many relationship declared with through: was loaded for a single record with a limit of 1, or an unsorted has_one through relationship was loaded with a limit of 1, lateral_join?/4 in lib/ash/actions/read/relationships.ex chose the path that reads the destination without any filter linking it to the source. The load returned the first destination record by sort, or any other record with an offset. The read still runs the destination's policies but carries the relationship as accessing_from, so a client paging such a field (for example teachers(limit: 1, offset: n) through AshGraphql) can enumerate destination records that policies allow only when reached through that relationship.

This issue affects ash: from 3.24.0 before 3.37.1.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-114214?

1 open source package ship an affected version, including ash.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash` | Hex | From 3.24.0 | 3.37.1 |

## How do I fix CVE-2026-114214?

Upgrade ash to 3.37.1 or later.

## Is CVE-2026-114214 being exploited?

There is no known exploitation of CVE-2026-114214 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114214 and fix it if it is affected.

What it is: CVE-2026-114214 is a medium-severity vulnerability in ash-project ash, published on 25 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114214 in the wild and no public exploit code.

Affected packages and fixed versions:
- ash (Hex): affected from 3.24.0; fixed in 3.37.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114214/ (Markdown: https://insights.sbomify.com/CVE-2026-114214/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114214
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114214
- OSV: https://osv.dev/vulnerability/CVE-2026-114214

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114214/
Summaries are generated and may contain mistakes; the official description above is the record.
