# CVE-2026-114362: HarnessRouter Targets Test Endpoint app.py server-side request forgery


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-c5g7-c47h-f6c3, GHSA-m79r-m5x7-m977

## What is CVE-2026-114362?

CVE-2026-114362 is a medium-severity vulnerability in HarnessRouter, published on 21 Oct 2026. 

### Official description

A flaw has been found in HarnessRouter up to 0.31.12. This impacts an unknown function of the file gateway/app.py of the component Targets Test Endpoint. Executing a manipulation of the argument base_url can lead to server-side request forgery. The attack may be performed from remote. Upgrading to version 0.31.13 will fix this issue. This patch is called 1c4b1fc1f89737dabd089ac1d1c174a57f764e28. It is suggested to upgrade the affected component.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-114362?


## How do I fix CVE-2026-114362?

No fix has been published for CVE-2026-114362 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-114362 being exploited?

There is no known exploitation of CVE-2026-114362 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114362 and fix it if it is affected.

What it is: CVE-2026-114362 is a medium-severity vulnerability in HarnessRouter, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114362 in the wild and no public exploit code.

Affected product: HarnessRouter. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114362/ (Markdown: https://insights.sbomify.com/CVE-2026-114362/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114362
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114362
- OSV: https://osv.dev/vulnerability/CVE-2026-114362

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114362/
Summaries are generated and may contain mistakes; the official description above is the record.
