# CVE-2026-114374: leomoon-studios wiki-go fetch-metadata Endpoint metadata_api.go server-side request forgery


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 21 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** GHSA-7q4p-98g4-pwp7, GHSA-p8fx-449f-qx64

## What is CVE-2026-114374?

CVE-2026-114374 is a medium-severity vulnerability in leomoon-studios wiki-go, published on 21 Oct 2026. 

### Official description

A vulnerability was identified in leomoon-studios wiki-go up to 1.9.1. This impacts an unknown function of the file internal/handlers/metadata_api.go of the component fetch-metadata Endpoint. Such manipulation leads to server-side request forgery. It is possible to launch the attack remotely. The exploit is publicly available and might be used. Upgrading to version 1.9.2 will fix this issue. The name of the patch is 25498ebf5c012b870967e38eec2a1e5133fa1a83. Upgrading the affected component is recommended.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-114374?


## How do I fix CVE-2026-114374?

No fix has been published for CVE-2026-114374 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-114374 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114374 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114374 and fix it if it is affected.

What it is: CVE-2026-114374 is a medium-severity vulnerability in leomoon-studios wiki-go, published on 21 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114374 exists.

Affected product: leomoon-studios wiki-go. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114374/ (Markdown: https://insights.sbomify.com/CVE-2026-114374/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114374
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114374
- OSV: https://osv.dev/vulnerability/CVE-2026-114374

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114374/
Summaries are generated and may contain mistakes; the official description above is the record.
