# CVE-2026-114386: Pydantic AI Harness before 0.59.0 CodeMode Tool Call Limit Bypass via run_code


- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** GHSA-3589-pxp7-3gj8

## What is CVE-2026-114386?

CVE-2026-114386 is a medium-severity vulnerability in pydantic-ai-harness, published on 21 Oct 2026. 

### Official description

Pydantic AI Harness before 0.59.0 fails to enforce UsageLimits.tool_calls_limit on nested tool calls dispatched from run_code in the CodeMode toolset. Users or prompt-injected content can make the sandboxed program invoke tools via run_nested_call() without check_before_tool_call, exceeding operator limits on costly or side-effecting tools.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-114386?

2 open source packages ship an affected version, including pydantic-ai-harness.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pydantic-ai-harness` | PyPI | All versions | 0.59.0 |
| `pydantic-ai-harness` | PyPI | All versions | 0.59.0 |

## How do I fix CVE-2026-114386?

Upgrade pydantic-ai-harness to 0.59.0 or later.

## Is CVE-2026-114386 being exploited?

There is no known exploitation of CVE-2026-114386 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114386 and fix it if it is affected.

What it is: CVE-2026-114386 is a medium-severity vulnerability in pydantic-ai-harness, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114386 in the wild and no public exploit code.

Affected packages and fixed versions:
- pydantic-ai-harness (PyPI): affected all versions; fixed in 0.59.0
- pydantic-ai-harness (PyPI): affected all versions; fixed in 0.59.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114386/ (Markdown: https://insights.sbomify.com/CVE-2026-114386/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114386
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114386
- OSV: https://osv.dev/vulnerability/CVE-2026-114386

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114386/
Summaries are generated and may contain mistakes; the official description above is the record.
