CVE-2026-11440 theonedev REST API default-branch improper authorization

Medium 5.3 Published Updated

Remote attackers can improperly modify the default branch of repositories via the REST API due to missing authorization checks in onedev.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-11440?

CVE-2026-11440 is a medium-severity missing authorization vulnerability in theonedev onedev, published on 6 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

A vulnerability was determined in theonedev onedev up to 15.0.5. This affects an unknown part of the file /repositories/{projectId}/default-branch of the component REST API. This manipulation of the argument project.defaultBranch causes improper authorization. It is possible to initiate the attack remotely. Upgrading to version 15.0.6 is able to mitigate this issue. Upgrading the affected component is advised.

Weakness: CWE-285, CWE-266

Which versions are affected by CVE-2026-11440?

How do I fix CVE-2026-11440?

No fix has been published for CVE-2026-11440 yet. Limit exposure of the affected software until one is available.

Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.

Is CVE-2026-11440 being exploited?

There is no known exploitation of CVE-2026-11440 in the wild and no public exploit code.

Sources

Also known as GHSA-2g53-8j24-x4mg.

Is CVE-2026-11440 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free