# CVE-2026-11440: theonedev REST API default-branch improper authorization

> Remote attackers can improperly modify the default branch of repositories via the REST API due to missing authorization checks in onedev.

- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:X`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 6 Jun 2026
- **Updated:** 8 Jun 2026
- **Also known as:** GHSA-2g53-8j24-x4mg

## What is CVE-2026-11440?

CVE-2026-11440 is a medium-severity missing authorization vulnerability in theonedev onedev, published on 6 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A vulnerability was determined in theonedev onedev up to 15.0.5. This affects an unknown part of the file /repositories/{projectId}/default-branch of the component REST API. This manipulation of the argument project.defaultBranch causes improper authorization. It is possible to initiate the attack remotely. Upgrading to version 15.0.6 is able to mitigate this issue. Upgrading the affected component is advised.

Weakness: CWE-285 (Improper Authorization), CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2026-11440?


## How do I fix CVE-2026-11440?

No fix has been published for CVE-2026-11440 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-11440 being exploited?

There is no known exploitation of CVE-2026-11440 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-11440 and fix it if it is affected.

What it is: CVE-2026-11440 is a medium-severity missing authorization vulnerability in theonedev onedev, published on 6 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-11440 in the wild and no public exploit code.

Affected product: theonedev onedev. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-11440/ (Markdown: https://insights.sbomify.com/CVE-2026-11440/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-11440
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-11440
- OSV: https://osv.dev/vulnerability/CVE-2026-11440

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-11440/
Summaries are generated and may contain mistakes; the official description above is the record.
