# CVE-2026-114509: Laravel TokenGuard authentication bypass through non-string API credentials


- **Severity:** Critical 9.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 21 Oct 2026
- **Updated:** 28 Oct 2026
- **Also known as:** CLSA-2026-1793031697, CLSA-2026-1793092408, CLSA-2026-1793190394, CLSA-2026-1793190457, CLSA-2026-1793190676, CLSA-2026-1793193622, CLSA-2026-1793193692, CLSA-2026-1793200604, CLSA-2026-1793275323, GHSA-f9x3-7vq9-cph6

## What is CVE-2026-114509?

CVE-2026-114509 is a critical vulnerability in laravel framework, published on 21 Oct 2026. 

### Official description

Laravel is a web application framework. Prior to 12.68.0 and 13.29.0, TokenGuard configured as a standard token-based API guard does not reject a crafted non-string credential. Under affected MySQL or MariaDB configurations, the authentication lookup can match an unintended existing user, allowing an unauthenticated attacker to bypass authentication and take over an account on routes protected by TokenGuard. This issue is fixed in versions 12.68.0 and 13.29.0.

Weakness: CWE-287 (Improper Authentication), CWE-1287 (Improper Validation of Specified Type of Input)

## Which versions are affected by CVE-2026-114509?

4 open source packages ship an affected version, including laravel/framework.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `laravel/framework` | Packagist | All versions | 12.68.0 |
| `laravel/framework` | Packagist | All versions | 12.68.0 |
| `laravel/framework` | Packagist | From 13.0.0 | 13.29.0 |
| `laravel/framework` | Packagist | From 13.0.0 | 13.29.0 |

## How do I fix CVE-2026-114509?

Upgrade laravel/framework to a fixed version for your release line: 12.68.0 or 13.29.0.

## Is CVE-2026-114509 being exploited?

There is no known exploitation of CVE-2026-114509 in the wild and no public exploit code.

Public exploit code:

- A poc for https://github.com/laravel/framework/security/advisories/GHSA-f9x3-7vq9-cph6 (github_poc): https://github.com/hakaioffsec/CVE-2026-114509-PoC
-  CVE-2026-114509-POC [Educational Purpose Only] (github_poc): https://github.com/tajulasri/-CVE-2026-114509-POC
- Reproducible local Laravel lab and self-checking PoC for CVE-2026-114509 (github_poc): https://github.com/dimasma0305/CVE-2026-114509
- CVE-2026-114509 — Laravel TokenGuard authentication bypass (CVSS 9.2): PoC, root-cause analysis, Docker lab, and reproduction guide (github_poc): https://github.com/ArioVeisa/cve-2026-114509-laravel-tokenguard
- Python detector for Laravel TokenGuard CVE-2026-114509 with local dependency analysis, remote authentication checks, and JSON reporting. (github_poc): https://github.com/mehmet-emir-eroglu/CVE-2026-114509
-  Laravel TokenGuard authentication bypass through non-string API credentials (github_poc): https://github.com/Nxploited/CVE-2026-114509

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114509 and fix it if it is affected.

What it is: CVE-2026-114509 is a critical vulnerability in laravel framework, published on 21 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114509 in the wild and no public exploit code.

Affected packages and fixed versions:
- laravel/framework (Packagist): affected all versions; fixed in 12.68.0
- laravel/framework (Packagist): affected all versions; fixed in 12.68.0
- laravel/framework (Packagist): affected from 13.0.0; fixed in 13.29.0
- laravel/framework (Packagist): affected from 13.0.0; fixed in 13.29.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114509/ (Markdown: https://insights.sbomify.com/CVE-2026-114509/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114509
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114509
- OSV: https://osv.dev/vulnerability/CVE-2026-114509

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114509/
Summaries are generated and may contain mistakes; the official description above is the record.
