# CVE-2026-114515: OCO-Server: Self-Service Portal uninstall-job authorization bypass


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 22 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** GHSA-34mv-3gjp-gf53

## What is CVE-2026-114515?

CVE-2026-114515 is a medium-severity vulnerability in schorschii OCO-Server, published on 22 Oct 2026. 

### Official description

OCO-Server is a self-hosted endpoint management application for computer inventory, software deployment, and mobile device management. Prior to 1.2.3, a valid Self-Service Portal user with permission to create job containers and read visibility on a computer and package can queue an uninstall job without deploy permission for those resources. Requests to `self-service/ajax-handler/job-containers.php` pass `uninstall_package_assignment_id[]` values to `lib/SelfService/CoreLogic.class.php::uninstallSelfService()`. Its permission-check loop continues after denied `METHOD_DEPLOY` checks without removing rejected IDs from `$installationIds`, then passes the original list to `lib/CoreLogic.class.php::uninstall()`. The CoreLogic object is constructed with a null SystemUser, causing `lib/CoreLogic.class.php::checkPermission()` to treat the operation as system context and unconditionally permit it. Enumerable `computer_package.id` values allow selection of readable installed-package assignments, including those on other users' computers. The `deploySelfService()` install path instead aborts on denied deployment permission, and resources lacking read permission remain blocked. This permits unauthorized software-removal jobs across resources visible to the acting user's role. This issue is fixed in version 1.2.3.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-114515?


## How do I fix CVE-2026-114515?

No fix has been published for CVE-2026-114515 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-114515 being exploited?

There is no known exploitation of CVE-2026-114515 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114515 and fix it if it is affected.

What it is: CVE-2026-114515 is a medium-severity vulnerability in schorschii OCO-Server, published on 22 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114515 in the wild and no public exploit code.

Affected product: schorschii OCO-Server. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114515/ (Markdown: https://insights.sbomify.com/CVE-2026-114515/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114515
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114515
- OSV: https://osv.dev/vulnerability/CVE-2026-114515

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114515/
Summaries are generated and may contain mistakes; the official description above is the record.
