# CVE-2026-114603: OpenTelemetry Python: Unbounded tracestate parsing in opentelemetry-api


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-114603, ECHO-235b-c8bb-c828, GHSA-xcq7-p3pf-p88h, MINI-jj2p-p345-6cmp, MINI-m8gq-62hm-gfh7, UBUNTU-CVE-2026-114603

## What is CVE-2026-114603?

CVE-2026-114603 is a medium-severity vulnerability in open-telemetry opentelemetry-python, published on 22 Oct 2026. 

### Official description

OpenTelemetry Python provides the Python API and SDK for OpenTelemetry. Prior to 1.45.1, the opentelemetry-api function TraceState.from_header in opentelemetry/trace/span.py, reached through TraceContextTextMapPropagator.extract, parses inbound W3C tracestate headers with an unbounded optional-whitespace regular expression. A malformed header containing a long run of spaces or tabs without a following comma causes quadratic backtracking before the member-count limit is applied. Services using the default W3C Trace Context propagator can therefore spend excessive CPU time on one unauthenticated request when the HTTP server, parser, gateway, or custom carrier accepts a sufficiently large header. The processing can occupy a synchronous worker or delay unrelated requests on the same asynchronous event loop. The impact is limited to availability and does not expose or modify telemetry data or allow code execution. This issue is fixed in version 1.45.1.

Weakness: CWE-400 (Uncontrolled Resource Consumption), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-114603?

2 open source packages ship an affected version, including opentelemetry-api.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `opentelemetry-api` | PyPI | All versions | 1.45.1 |
| `opentelemetry-api` | PyPI | All versions | 1.45.1 |

## How do I fix CVE-2026-114603?

Upgrade opentelemetry-api to 1.45.1 or later.

## Is CVE-2026-114603 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114603 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114603 and fix it if it is affected.

What it is: CVE-2026-114603 is a medium-severity vulnerability in open-telemetry opentelemetry-python, published on 22 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114603 exists.

Affected packages and fixed versions:
- opentelemetry-api (PyPI): affected all versions; fixed in 1.45.1
- opentelemetry-api (PyPI): affected all versions; fixed in 1.45.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114603/ (Markdown: https://insights.sbomify.com/CVE-2026-114603/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114603
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114603
- OSV: https://osv.dev/vulnerability/CVE-2026-114603

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114603/
Summaries are generated and may contain mistakes; the official description above is the record.
