# CVE-2026-114605: dnspython dns.name.from_wire_parser() excessive CPU use


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** AZL-111002, DEBIAN-CVE-2026-114605, ECHO-204d-228d-37f9, GHSA-45c3-73f7-pv4m, MINI-cpr4-788r-vmqh, MINI-rxgj-627r-fgrf, MINI-xf5j-wvg9-272x, UBUNTU-CVE-2026-114605

## What is CVE-2026-114605?

CVE-2026-114605 is a high-severity vulnerability in rthalley dnspython, published on 22 Oct 2026. 

### Official description

dnspython is a DNS toolkit for Python. Prior to 2.9.0, dns.name.from_wire_parser follows attacker-controlled DNS compression pointer chains without a hop limit. A malicious DNS wire-format message can force excessive pointer traversal during name decompression, causing high CPU use, application degradation, or denial of service in applications that process untrusted DNS messages. This issue is fixed in version 2.9.0.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-114605?

2 open source packages ship an affected version, including dnspython.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dnspython` | PyPI | All versions | 2.9.0 |
| `dnspython` | PyPI | All versions | 2.9.0 |

## How do I fix CVE-2026-114605?

Upgrade dnspython to 2.9.0 or later.

## Is CVE-2026-114605 being exploited?

There is no known exploitation of CVE-2026-114605 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114605 and fix it if it is affected.

What it is: CVE-2026-114605 is a high-severity vulnerability in rthalley dnspython, published on 22 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114605 in the wild and no public exploit code.

Affected packages and fixed versions:
- dnspython (PyPI): affected all versions; fixed in 2.9.0
- dnspython (PyPI): affected all versions; fixed in 2.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114605/ (Markdown: https://insights.sbomify.com/CVE-2026-114605/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114605
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114605
- OSV: https://osv.dev/vulnerability/CVE-2026-114605

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114605/
Summaries are generated and may contain mistakes; the official description above is the record.
