# CVE-2026-114608: Pylint: Arbitrary code execution via pickle deserialization of the stats cache in PYLINT_HOME


- **Severity:** Medium 5.4 (`CVSS:4.0/AV:L/AC:H/AT:P/PR:L/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** AZL-110543, DEBIAN-CVE-2026-114608, GHSA-22qq-2fwx-7p67, UBUNTU-CVE-2026-114608

## What is CVE-2026-114608?

CVE-2026-114608 is a medium-severity vulnerability in pylint-dev pylint, published on 22 Oct 2026. 

### Official description

Pylint is a static code analyser for Python. From 0.15.2 until 4.0.9, Pylint stores module statistics in predictable files under PYLINT_HOME and loads those files with pickle.load on a later run. An attacker who can write to a shared, group-writable, or otherwise untrusted cache directory can replace a stats cache with crafted serialized data, causing arbitrary code to execute with the privileges of the user who next runs Pylint. The default per-user cache is not normally writable by another user. This issue is fixed in version 4.0.9.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2026-114608?

2 open source packages ship an affected version, including pylint.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pylint` | PyPI | All versions | 4.0.9 |
| `pylint` | PyPI | All versions | 4.0.9 |

## How do I fix CVE-2026-114608?

Upgrade pylint to 4.0.9 or later.

## Is CVE-2026-114608 being exploited?

There is no known exploitation of CVE-2026-114608 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114608 and fix it if it is affected.

What it is: CVE-2026-114608 is a medium-severity vulnerability in pylint-dev pylint, published on 22 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114608 in the wild and no public exploit code.

Affected packages and fixed versions:
- pylint (PyPI): affected all versions; fixed in 4.0.9
- pylint (PyPI): affected all versions; fixed in 4.0.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114608/ (Markdown: https://insights.sbomify.com/CVE-2026-114608/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114608
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114608
- OSV: https://osv.dev/vulnerability/CVE-2026-114608

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114608/
Summaries are generated and may contain mistakes; the official description above is the record.
