# CVE-2026-114610: fpdf2: Exponential SVG '<use>' expansion causes CPU and memory exhaustion in 'FPDF.image()'


- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-114610, GHSA-wqw6-wpr3-45rh

## What is CVE-2026-114610?

CVE-2026-114610 is a medium-severity vulnerability in py-pdf fpdf2, published on 22 Oct 2026. 

### Official description

fpdf2 is a PDF creation library for Python. From 2.5.0 until 2.8.8, fpdf2's SVGObject.build_xref() passes nested SVG <use> references to GraphicsContext.add_item(), whose default clone=True deep-copy behavior copies the complete referenced graphics tree during FPDF.image() processing. Repeating references at each nesting level makes the in-memory object count and processing work grow exponentially, allowing a small user-controlled SVG to consume excessive CPU and memory, raise MemoryError, fail PDF generation jobs, and reduce or exhaust worker capacity. ResourceAccessPolicy does not prevent the issue because the references are inline and require no external resource, XML entity, local file, or permissive network setting. This issue is fixed in version 2.8.8.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-114610?

2 open source packages ship an affected version, including fpdf2.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fpdf2` | PyPI | From 2.5.0 | 2.8.8 |
| `fpdf2` | PyPI | From 2.5.0 | 2.8.8 |

## How do I fix CVE-2026-114610?

Upgrade fpdf2 to 2.8.8 or later.

## Is CVE-2026-114610 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114610 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114610 and fix it if it is affected.

What it is: CVE-2026-114610 is a medium-severity vulnerability in py-pdf fpdf2, published on 22 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114610 exists.

Affected packages and fixed versions:
- fpdf2 (PyPI): affected from 2.5.0; fixed in 2.8.8
- fpdf2 (PyPI): affected from 2.5.0; fixed in 2.8.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114610/ (Markdown: https://insights.sbomify.com/CVE-2026-114610/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114610
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114610
- OSV: https://osv.dev/vulnerability/CVE-2026-114610

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114610/
Summaries are generated and may contain mistakes; the official description above is the record.
