# CVE-2026-114613: MessagePack: Unbounded memory leak in msgpack C extension on strict_map_key validation failure


- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** AZL-111044, DEBIAN-CVE-2026-114613, ECHO-3ddd-55c2-b818, GHSA-j586-36cw-2gc2, MINI-54jj-x2mq-hf2m, MINI-55vq-gf8w-crh2, MINI-fg2p-hwgm-r8cx

## What is CVE-2026-114613?

CVE-2026-114613 is a high-severity vulnerability in msgpack-python, published on 22 Oct 2026. 

### Official description

MessagePack is the serializer implementation for Python msgpack.org. Prior to 1.2.3, the msgpack-python C extension (msgpack._cmsgpack) leaks a decoded map value when deserialization rejects a key with strict_map_key=True (the default). Repeated malformed inputs can cause unbounded process memory growth and denial of service in applications that deserialize attacker-controlled MessagePack data. Both unpackb() and the streaming Unpacker API are affected. The pure-Python fallback does not exhibit this leak in the reported tests. This issue is fixed in version 1.2.3.

Weakness: CWE-401 (Missing Release of Memory after Effective Lifetime)

## Which versions are affected by CVE-2026-114613?

2 open source packages ship an affected version, including msgpack.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `msgpack` | PyPI | All versions | 1.2.3 |
| `msgpack` | PyPI | All versions | 1.2.3 |

## How do I fix CVE-2026-114613?

Upgrade msgpack to 1.2.3 or later.

## Is CVE-2026-114613 being exploited?

There is no known exploitation of CVE-2026-114613 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114613 and fix it if it is affected.

What it is: CVE-2026-114613 is a high-severity vulnerability in msgpack-python, published on 22 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114613 in the wild and no public exploit code.

Affected packages and fixed versions:
- msgpack (PyPI): affected all versions; fixed in 1.2.3
- msgpack (PyPI): affected all versions; fixed in 1.2.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114613/ (Markdown: https://insights.sbomify.com/CVE-2026-114613/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114613
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114613
- OSV: https://osv.dev/vulnerability/CVE-2026-114613

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114613/
Summaries are generated and may contain mistakes; the official description above is the record.
