{"answers":{"affected":"2 open source packages ship an affected version, including authlib. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114618 exists.","fix":"Upgrade authlib to 1.9.0 or later.","what":"CVE-2026-114618 is a medium-severity vulnerability in authlib, published on 22 Oct 2026."},"fix_prompt":"Check this codebase for CVE-2026-114618 and fix it if it is affected.\n\nWhat it is: CVE-2026-114618 is a medium-severity vulnerability in authlib, published on 22 Oct 2026. \nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114618 exists.\n\nAffected packages and fixed versions:\n- authlib (PyPI): affected all versions; fixed in 1.9.0\n- authlib (PyPI): affected all versions; fixed in 1.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-114618/ (Markdown: https://insights.sbomify.com/CVE-2026-114618/index.md)","id":"CVE-2026-114618","markdown":"https://insights.sbomify.com/CVE-2026-114618/index.md","name":"CVE-2026-114618","record":{"aliases":["DEBIAN-CVE-2026-114618","ECHO-c817-2bcc-5ece","GHSA-fch4-3c6x-j4gc","MINI-69gh-wcqm-4p32","UBUNTU-CVE-2026-114618"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[{"product":"authlib","vendor":"authlib"}],"cvss":{"score":6.8,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-287","name":"Improper Authentication"},{"id":"CWE-1188","name":"Initialization of a Resource with an Insecure Default"}],"description":"Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to 1.9.0, the default RFC 7523 JWTBearerGrant.get_audiences() returns an empty list, causing JWTBearerGrant.verify_claims() to require only that an aud claim exists without matching the current authorization server. An attacker holding a legitimate assertion for another service can present it to a server that shares the signing key and uses the default grant, obtaining an access token across a trust boundary. Implementations that override get_audiences() with the server's valid audience identifiers are not affected. This issue is fixed in version 1.9.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Authlib: Default JWT bearer grant accepts assertions for the wrong audience","id":"CVE-2026-114618","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":null,"year":"2026"},"n_packages":2,"n_references":4,"next":{"headline":"Authlib: OpenID implicit grant checks raw scope instead of allowed scope before issuing ID tokens","id":"CVE-2026-114619"},"packages":[{"ecosystem":"PyPI","fixed":["1.9.0"],"introduced":["0"],"last_affected":[],"package":"authlib","purl":null,"source":"GHSA-fch4-3c6x-j4gc"},{"ecosystem":"PyPI","fixed":["1.9.0"],"introduced":["0"],"last_affected":[],"package":"authlib","purl":"pkg:pypi/authlib","source":"GHSA-fch4-3c6x-j4gc"}],"prev":{"headline":"Authlib: ID token can disable its own nonce validation via the nonce_supported claim","id":"CVE-2026-114617"},"products":["authlib"],"published":"2026-10-22","related":[{"cvss_score":9.1,"headline":"Authlib JWS JWK Header Injection: Signature Verification Bypass","id":"CVE-2026-27962","kev_date_added":null,"published":"2026-03-16"},{"cvss_score":8.3,"headline":"Authlib Vulnerable to JWE RSA1_5 Bleichenbacher Padding Oracle","id":"CVE-2026-28490","kev_date_added":null,"published":"2026-03-16"},{"cvss_score":8.2,"headline":"Authlib: Fail-Open Cryptographic Verification in OIDC Hash Binding","id":"CVE-2026-28498","kev_date_added":null,"published":"2026-03-16"},{"cvss_score":7.7,"headline":"Authlib: Setting `alg: none` and a blank signature appears to bypass signature verification","id":"CVE-2026-28802","kev_date_added":null,"published":"2026-03-06"},{"cvss_score":7.5,"headline":"Authlib is vulnerable to Denial of Service via Oversized JOSE Segments","id":"CVE-2025-61920","kev_date_added":null,"published":"2025-10-10"},{"cvss_score":7.5,"headline":"Authlib: JWS/JWT accepts unknown crit headers (RFC violation → possible authz bypass)","id":"CVE-2025-59420","kev_date_added":null,"published":"2025-09-22"},{"cvss_score":7.5,"headline":"Authlib has algorithm confusion with asymmetric public keys","id":"CVE-2024-37568","kev_date_added":null,"published":"2024-06-09"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-29","vendors":["authlib"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-114618/"}