# CVE-2026-114618: Authlib: Default JWT bearer grant accepts assertions for the wrong audience


- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-114618, ECHO-c817-2bcc-5ece, GHSA-fch4-3c6x-j4gc, MINI-69gh-wcqm-4p32, UBUNTU-CVE-2026-114618

## What is CVE-2026-114618?

CVE-2026-114618 is a medium-severity vulnerability in authlib, published on 22 Oct 2026. 

### Official description

Authlib is a Python library which builds OAuth and OpenID Connect servers. Prior to 1.9.0, the default RFC 7523 JWTBearerGrant.get_audiences() returns an empty list, causing JWTBearerGrant.verify_claims() to require only that an aud claim exists without matching the current authorization server. An attacker holding a legitimate assertion for another service can present it to a server that shares the signing key and uses the default grant, obtaining an access token across a trust boundary. Implementations that override get_audiences() with the server's valid audience identifiers are not affected. This issue is fixed in version 1.9.0.

Weakness: CWE-287 (Improper Authentication), CWE-1188 (Initialization of a Resource with an Insecure Default)

## Which versions are affected by CVE-2026-114618?

2 open source packages ship an affected version, including authlib. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authlib` | PyPI | All versions | 1.9.0 |
| `authlib` | PyPI | All versions | 1.9.0 |

Products: Authlib Authlib.

## How do I fix CVE-2026-114618?

Upgrade authlib to 1.9.0 or later.

## Is CVE-2026-114618 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114618 exists.

## Other vulnerabilities in authlib

- [CVE-2026-27962](https://insights.sbomify.com/CVE-2026-27962/): Authlib JWS JWK Header Injection: Signature Verification Bypass (critical 9.1)
- [CVE-2026-28490](https://insights.sbomify.com/CVE-2026-28490/): Authlib Vulnerable to JWE RSA1_5 Bleichenbacher Padding Oracle (high 8.3)
- [CVE-2026-28498](https://insights.sbomify.com/CVE-2026-28498/): Authlib: Fail-Open Cryptographic Verification in OIDC Hash Binding (high 8.2)
- [CVE-2026-28802](https://insights.sbomify.com/CVE-2026-28802/): Authlib: Setting `alg: none` and a blank signature appears to bypass signature verification (high 7.7)
- [CVE-2025-61920](https://insights.sbomify.com/CVE-2025-61920/): Authlib is vulnerable to Denial of Service via Oversized JOSE Segments (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114618 and fix it if it is affected.

What it is: CVE-2026-114618 is a medium-severity vulnerability in authlib, published on 22 Oct 2026. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-114618 exists.

Affected packages and fixed versions:
- authlib (PyPI): affected all versions; fixed in 1.9.0
- authlib (PyPI): affected all versions; fixed in 1.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114618/ (Markdown: https://insights.sbomify.com/CVE-2026-114618/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114618
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114618
- OSV: https://osv.dev/vulnerability/CVE-2026-114618

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114618/
Summaries are generated and may contain mistakes; the official description above is the record.
