# CVE-2026-114621: baserCMS: SQL injection in the admin panel and admin API


- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 23 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-2w6g-wp3r-26m3

## What is CVE-2026-114621?

CVE-2026-114621 is a high-severity vulnerability in baserproject basercms, published on 23 Oct 2026. 

### Official description

baserCMS is a website development framework. In versions 5.0.0 before 5.3.2 and 5.4.0 before 5.4.2, list and detail actions in the Admin and Api/Admin prefixes pass request query parameters, including contain, conditions, fields, finder, and order, directly to the ORM as options. A user able to log into the admin panel can embed SQL fragments in those options to execute arbitrary SQL against the application's database, including reading password hashes from the users table. Public-page and public-API fixes released in 5.3.1 and 5.4.1 did not protect these administrative paths. Setting USE_CORE_ADMIN_API to false does not prevent access through an authenticated browser session. This issue has been patched in versions 5.3.2 and 5.4.2.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-114621?


## How do I fix CVE-2026-114621?

No fix has been published for CVE-2026-114621 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-114621 being exploited?

There is no known exploitation of CVE-2026-114621 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-114621 and fix it if it is affected.

What it is: CVE-2026-114621 is a high-severity vulnerability in baserproject basercms, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-114621 in the wild and no public exploit code.

Affected product: baserproject basercms. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-114621/ (Markdown: https://insights.sbomify.com/CVE-2026-114621/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-114621
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-114621
- OSV: https://osv.dev/vulnerability/CVE-2026-114621

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-114621/
Summaries are generated and may contain mistakes; the official description above is the record.
