# CVE-2026-115356: OpenBao before 2.6.4 and 2.7.0 before 2.7.1 Kubernetes Auth Method Token Renewal After Revocation


- **Severity:** Medium 5.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** BIT-openbao-2026-115356, GHSA-gf3j-hm38-jhh5, GHSA-qmv6-f44g-mj35

## What is CVE-2026-115356?

CVE-2026-115356 is a medium-severity vulnerability in openbao, published on 22 Oct 2026. 

### Official description

OpenBao before 2.6.4 and 2.7.x before 2.7.1 does not verify, when renewing a token issued by the Kubernetes Auth method, that the service account token originally used to authenticate is still valid. An authenticated attacker can keep renewing such tokens to persist access after the Kubernetes service account has been deleted.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2026-115356?

1 open source package ship an affected version, including openbao.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openbao` | Bitnami | All versions | 2.6.4, 2.7.1 |

## How do I fix CVE-2026-115356?

Upgrade openbao to a fixed version for your release line: 2.6.4 or 2.7.1.

## Is CVE-2026-115356 being exploited?

There is no known exploitation of CVE-2026-115356 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115356 and fix it if it is affected.

What it is: CVE-2026-115356 is a medium-severity vulnerability in openbao, published on 22 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115356 in the wild and no public exploit code.

Affected packages and fixed versions:
- openbao (Bitnami): affected all versions; fixed in 2.6.4, 2.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115356/ (Markdown: https://insights.sbomify.com/CVE-2026-115356/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115356
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115356
- OSV: https://osv.dev/vulnerability/CVE-2026-115356

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115356/
Summaries are generated and may contain mistakes; the official description above is the record.
