{"answers":{"affected":"1 open source package ship an affected version, including openbao.","exploited":"There is no known exploitation of CVE-2026-115358 in the wild and no public exploit code.","fix":"Upgrade openbao to a fixed version for your release line: 2.6.3 or 2.7.1.","what":"CVE-2026-115358 is a low-severity vulnerability in openbao, published on 22 Oct 2026."},"fix_prompt":"Check this codebase for CVE-2026-115358 and fix it if it is affected.\n\nWhat it is: CVE-2026-115358 is a low-severity vulnerability in openbao, published on 22 Oct 2026. \nExploitation: There is no known exploitation of CVE-2026-115358 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openbao (Bitnami): affected all versions; fixed in 2.6.3, 2.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-115358/ (Markdown: https://insights.sbomify.com/CVE-2026-115358/index.md)","id":"CVE-2026-115358","markdown":"https://insights.sbomify.com/CVE-2026-115358/index.md","name":"CVE-2026-115358","record":{"aliases":["BIT-openbao-2026-115358","GHSA-8xxq-mq9m-xmhw","GHSA-h7rj-f8m2-hv6h"],"analysis":null,"analysis_generated_by":null,"assigner":"VulnCheck","cpe":[],"cvss":{"score":2,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-532","name":"Insertion of Sensitive Information into Log File"}],"description":"OpenBao before 2.6.3 contains an information disclosure vulnerability that allows attackers to leak sensitive data into audit logs by sending malformed plugin parameters. Attackers can submit requests with malformed TypeKVPair or TypeHeader field values, causing error messages containing sensitive input to be recorded in audit logs.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenBao before 2.6.3 Sensitive Data Leak in Audit Log via Malformed Parameters","id":"CVE-2026-115358","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":null,"year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"OpenBao before 2.6.4 and 2.7.0 before 2.7.1 Role-Based Rate Limit Quota Bypass via Request Parsing","id":"CVE-2026-115359"},"packages":[{"ecosystem":"Bitnami","fixed":["2.6.3","2.7.1"],"introduced":["0","2.7.0"],"last_affected":[],"package":"openbao","purl":"pkg:bitnami/openbao","source":"BIT-openbao-2026-115358"}],"prev":{"headline":"OpenBao before 2.6.4 and 2.7.0 before 2.7.1 Improper Audit Logging of Root Generation and Rekey Responses","id":"CVE-2026-115357"},"products":["openbao"],"published":"2026-10-22","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-29","vendors":["openbao"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-115358/"}