CVE-2026-115362 OpenBao before 2.6.4 and 2.7.0 before 2.7.1 Expired AppRole SecretID Authentication Bypass
- Exploited in the wild
- Not known
- Fix
- Available
What is CVE-2026-115362?
CVE-2026-115362 is a low-severity vulnerability in openbao, published on 22 Oct 2026.
Official description
OpenBao before 2.6.4 and 2.7.x before 2.7.1 does not check Secret ID expiration at use in the AppRole auth method, leaving expired Secret IDs valid until the periodic tidy removes them. An attacker holding an expired, untidied Secret ID can log in and gain access beyond its TTL.
Weakness: CWE-613
Which versions are affected by CVE-2026-115362?
1 open source package ship an affected version, including openbao.
| Package | Affected | Fixed in |
|---|---|---|
openbao Bitnami | All versions | 2.6.4, 2.7.1 |
How do I fix CVE-2026-115362?
Upgrade openbao to a fixed version for your release line: 2.6.4 or 2.7.1.
Is CVE-2026-115362 being exploited?
There is no known exploitation of CVE-2026-115362 in the wild and no public exploit code.
Sources
Also known as BIT-openbao-2026-115362, GHSA-7m59-mp95-w6ph, GHSA-95v7-85fw-x99g.