{"answers":{"affected":"1 open source package ship an affected version, including openbao.","exploited":"There is no known exploitation of CVE-2026-115362 in the wild and no public exploit code.","fix":"Upgrade openbao to a fixed version for your release line: 2.6.4 or 2.7.1.","what":"CVE-2026-115362 is a low-severity vulnerability in openbao, published on 22 Oct 2026."},"fix_prompt":"Check this codebase for CVE-2026-115362 and fix it if it is affected.\n\nWhat it is: CVE-2026-115362 is a low-severity vulnerability in openbao, published on 22 Oct 2026. \nExploitation: There is no known exploitation of CVE-2026-115362 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openbao (Bitnami): affected all versions; fixed in 2.6.4, 2.7.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-115362/ (Markdown: https://insights.sbomify.com/CVE-2026-115362/index.md)","id":"CVE-2026-115362","markdown":"https://insights.sbomify.com/CVE-2026-115362/index.md","name":"CVE-2026-115362","record":{"aliases":["BIT-openbao-2026-115362","GHSA-7m59-mp95-w6ph","GHSA-95v7-85fw-x99g"],"analysis":null,"analysis_generated_by":null,"assigner":"VulnCheck","cpe":[],"cvss":{"score":2.1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"}],"description":"OpenBao before 2.6.4 and 2.7.x before 2.7.1 does not check Secret ID expiration at use in the AppRole auth method, leaving expired Secret IDs valid until the periodic tidy removes them. An attacker holding an expired, untidied Secret ID can log in and gain access beyond its TTL.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenBao before 2.6.4 and 2.7.0 before 2.7.1 Expired AppRole SecretID Authentication Bypass","id":"CVE-2026-115362","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":null,"year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"OpenBao 2.2.0 before 2.6.4 and 2.7.0 before 2.7.1 ACME EAB MAC Key Disclosure via Sanitized Configuration","id":"CVE-2026-115363"},"packages":[{"ecosystem":"Bitnami","fixed":["2.6.4","2.7.1"],"introduced":["0","2.7.0"],"last_affected":[],"package":"openbao","purl":"pkg:bitnami/openbao","source":"BIT-openbao-2026-115362"}],"prev":{"headline":"OpenBao before 2.6.3 ACL Bypass via Dropped Templated Policy Denial","id":"CVE-2026-115361"},"products":["openbao"],"published":"2026-10-22","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-29","vendors":["openbao"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-115362/"}