# CVE-2026-115362: OpenBao before 2.6.4 and 2.7.0 before 2.7.1 Expired AppRole SecretID Authentication Bypass


- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** BIT-openbao-2026-115362, GHSA-7m59-mp95-w6ph, GHSA-95v7-85fw-x99g

## What is CVE-2026-115362?

CVE-2026-115362 is a low-severity vulnerability in openbao, published on 22 Oct 2026. 

### Official description

OpenBao before 2.6.4 and 2.7.x before 2.7.1 does not check Secret ID expiration at use in the AppRole auth method, leaving expired Secret IDs valid until the periodic tidy removes them. An attacker holding an expired, untidied Secret ID can log in and gain access beyond its TTL.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2026-115362?

1 open source package ship an affected version, including openbao.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `openbao` | Bitnami | All versions | 2.6.4, 2.7.1 |

## How do I fix CVE-2026-115362?

Upgrade openbao to a fixed version for your release line: 2.6.4 or 2.7.1.

## Is CVE-2026-115362 being exploited?

There is no known exploitation of CVE-2026-115362 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115362 and fix it if it is affected.

What it is: CVE-2026-115362 is a low-severity vulnerability in openbao, published on 22 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115362 in the wild and no public exploit code.

Affected packages and fixed versions:
- openbao (Bitnami): affected all versions; fixed in 2.6.4, 2.7.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115362/ (Markdown: https://insights.sbomify.com/CVE-2026-115362/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115362
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115362
- OSV: https://osv.dev/vulnerability/CVE-2026-115362

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115362/
Summaries are generated and may contain mistakes; the official description above is the record.
