{"answers":{"affected":"1 open source package ship an affected version, including openbao.","exploited":"There is no known exploitation of CVE-2026-115364 in the wild and no public exploit code.","fix":"Upgrade openbao to 2.6.3 or later.","what":"CVE-2026-115364 is a low-severity vulnerability in openbao, published on 22 Oct 2026."},"fix_prompt":"Check this codebase for CVE-2026-115364 and fix it if it is affected.\n\nWhat it is: CVE-2026-115364 is a low-severity vulnerability in openbao, published on 22 Oct 2026. \nExploitation: There is no known exploitation of CVE-2026-115364 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openbao (Bitnami): affected all versions; fixed in 2.6.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-115364/ (Markdown: https://insights.sbomify.com/CVE-2026-115364/index.md)","id":"CVE-2026-115364","markdown":"https://insights.sbomify.com/CVE-2026-115364/index.md","name":"CVE-2026-115364","record":{"aliases":["BIT-openbao-2026-115364","GHSA-8gmq-wv9h-fcwp","GHSA-rw7f-qpfc-j3vm"],"analysis":null,"analysis_generated_by":null,"assigner":"VulnCheck","cpe":[],"cvss":{"score":2.1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:N/VA:L/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-862","name":"Missing Authorization"}],"description":"OpenBao before 2.6.3 contains a missing authorization check that allows attackers to stop Agent and Proxy services by omitting the X-Vault-Header. When require_request_header is enabled, attackers can send requests via server-side request forgery to /agent/v1/quit or /proxy/v1/quit to shut down these services.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenBao before 2.6.3 Missing Header Check on Agent/Proxy Quit Endpoints","id":"CVE-2026-115364","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":null,"year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"OpenBao 2.3.0 before 2.6.3 Incorrect Authorization via Policy Cache Namespace Traversal","id":"CVE-2026-115365"},"packages":[{"ecosystem":"Bitnami","fixed":["2.6.3"],"introduced":["0"],"last_affected":[],"package":"openbao","purl":"pkg:bitnami/openbao","source":"BIT-openbao-2026-115364"}],"prev":{"headline":"OpenBao 2.2.0 before 2.6.4 and 2.7.0 before 2.7.1 ACME EAB MAC Key Disclosure via Sanitized Configuration","id":"CVE-2026-115363"},"products":["openbao"],"published":"2026-10-22","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-23","vendors":["openbao"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-115364/"}