{"answers":{"affected":"1 open source package ship an affected version, including openbao.","exploited":"There is no known exploitation of CVE-2026-115369 in the wild and no public exploit code.","fix":"Upgrade openbao to 2.6.2 or later.","what":"CVE-2026-115369 is a low-severity vulnerability in openbao, published on 22 Oct 2026."},"fix_prompt":"Check this codebase for CVE-2026-115369 and fix it if it is affected.\n\nWhat it is: CVE-2026-115369 is a low-severity vulnerability in openbao, published on 22 Oct 2026. \nExploitation: There is no known exploitation of CVE-2026-115369 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- openbao (Bitnami): affected from 2.5.0; fixed in 2.6.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-115369/ (Markdown: https://insights.sbomify.com/CVE-2026-115369/index.md)","id":"CVE-2026-115369","markdown":"https://insights.sbomify.com/CVE-2026-115369/index.md","name":"CVE-2026-115369","record":{"aliases":["BIT-openbao-2026-115369","GHSA-65vq-mjjr-475v","GHSA-g892-p242-8g86"],"analysis":null,"analysis_generated_by":null,"assigner":"VulnCheck","cpe":[],"cvss":{"score":2.1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:H/UI:N/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"OpenBao from 2.5.0 before 2.6.2 fails to enforce the PKI role allowed_ip_sans_cidr restriction on IP SANs taken from a CSR when use_csr_sans is enabled. Authenticated callers with sign permission can submit a CSR with an out-of-range IP SAN to pki/sign/\u003crole\u003e and obtain CA-signed certificates for unauthorized IPs.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"OpenBao 2.5.0 before 2.6.2 PKI allowed_ip_sans_cidr Bypass via CSR IP SANs","id":"CVE-2026-115369","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":null,"year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"Incus 6.0.5 before 6.0.7, 6.12.0 before 7.0.2, and 7.1.0 before 7.5.0 contains a restriction bypass vulnerability that allows restricted pro","id":"CVE-2026-115370"},"packages":[{"ecosystem":"Bitnami","fixed":["2.6.2"],"introduced":["2.5.0"],"last_affected":[],"package":"openbao","purl":"pkg:bitnami/openbao","source":"BIT-openbao-2026-115369"}],"prev":{"headline":"OpenBao 2.3.0 before 2.6.3 Missing Root Namespace Enforcement in Plugin Catalog APIs","id":"CVE-2026-115366"},"products":["openbao"],"published":"2026-10-22","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-29","vendors":["openbao"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-115369/"}