# CVE-2026-115381: Wasmtime before 36.0.17, 37.0.0 before 48.0.4, and 49.0.0 before 49.0.2 contains an unbounded memory allocation in the wasmtime-wasi WASIp2


- **Severity:** Medium 5.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-115381, GHSA-gqmc-89g8-p25r, GHSA-m3j5-9cx2-7c68, RUSTSEC-2026-0322, UBUNTU-CVE-2026-115381

## What is CVE-2026-115381?

CVE-2026-115381 is a medium-severity vulnerability in bytecodealliance wasmtime, published on 22 Oct 2026. 

### Official description

Wasmtime before 36.0.17, 37.0.0 before 48.0.4, and 49.0.0 before 49.0.2 contains an unbounded memory allocation in the wasmtime-wasi WASIp2 write-zeroes method of SinkOutputStream, the default stream used when stdout/stderr are not configured. A malicious WebAssembly guest can request huge zero-filled writes, exhausting host memory and causing denial of service.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-115381?

1 open source package ship an affected version, including wasmtime-wasi.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wasmtime-wasi` | crates.io | From 0.0.0-0 | 36.0.17, 48.0.4, 49.0.2 |

## How do I fix CVE-2026-115381?

Upgrade wasmtime-wasi to a fixed version for your release line: 36.0.17, 48.0.4 or 49.0.2.

## Is CVE-2026-115381 being exploited?

There is no known exploitation of CVE-2026-115381 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115381 and fix it if it is affected.

What it is: CVE-2026-115381 is a medium-severity vulnerability in bytecodealliance wasmtime, published on 22 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115381 in the wild and no public exploit code.

Affected packages and fixed versions:
- wasmtime-wasi (crates.io): affected from 0.0.0-0; fixed in 36.0.17, 48.0.4, 49.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115381/ (Markdown: https://insights.sbomify.com/CVE-2026-115381/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115381
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115381
- OSV: https://osv.dev/vulnerability/CVE-2026-115381

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115381/
Summaries are generated and may contain mistakes; the official description above is the record.
