# CVE-2026-115382: Wasmtime 46.0.0 before 48.0.4 and 49.0.0 before 49.0.2 wasi:http Zero Timeout Panic DoS


- **Severity:** Medium 5.9 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** GHSA-5gfg-32ph-pxg9, GHSA-w4qr-p94g-mjhv, RUSTSEC-2026-0320, UBUNTU-CVE-2026-115382

## What is CVE-2026-115382?

CVE-2026-115382 is a medium-severity vulnerability in bytecodealliance wasmtime, published on 22 Oct 2026. 

### Official description

Wasmtime 46.0.0 before 48.0.4 and 49.0.0 before 49.0.2 contains a denial-of-service vulnerability in its wasi:http implementation that allows guests to panic the host. Guests can specify a zero between-bytes-timeout request option, which is forwarded directly to a Tokio API that panics, crashing the host embedding.

Weakness: CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2026-115382?

1 open source package ship an affected version, including wasmtime-wasi-http.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wasmtime-wasi-http` | crates.io | From 46.0.0 | 48.0.4, 49.0.2 |

## How do I fix CVE-2026-115382?

Upgrade wasmtime-wasi-http to a fixed version for your release line: 48.0.4 or 49.0.2.

## Is CVE-2026-115382 being exploited?

There is no known exploitation of CVE-2026-115382 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115382 and fix it if it is affected.

What it is: CVE-2026-115382 is a medium-severity vulnerability in bytecodealliance wasmtime, published on 22 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115382 in the wild and no public exploit code.

Affected packages and fixed versions:
- wasmtime-wasi-http (crates.io): affected from 46.0.0; fixed in 48.0.4, 49.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115382/ (Markdown: https://insights.sbomify.com/CVE-2026-115382/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115382
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115382
- OSV: https://osv.dev/vulnerability/CVE-2026-115382

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115382/
Summaries are generated and may contain mistakes; the official description above is the record.
