# CVE-2026-115384: Wasmtime 39.0.0 before 48.0.4 and 49.0.0 before 49.0.2 Stack Buffer Overflow


- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** AZL-111011, AZL-111026, AZL-111077, AZL-111086, GHSA-32h6-97mm-8q3c, GHSA-6fff-wrjr-wjxr, RUSTSEC-2026-0327, UBUNTU-CVE-2026-115384

## What is CVE-2026-115384?

CVE-2026-115384 is a critical vulnerability in bytecodealliance wasmtime, published on 22 Oct 2026. 

### Official description

Wasmtime 39.0.0 before 48.0.4 and 49.0.0 before 49.0.2 contains a stack buffer overflow vulnerability that allows malicious guests to write ~16KB to the native stack via unvalidated async callback result types. Attackers can supply components with mistyped component-model-async callback functions to overwrite return addresses, crashing the host or escaping the sandbox.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-115384?

1 open source package ship an affected version, including wasmtime.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wasmtime` | crates.io | From 39.0.0 | 48.0.4, 49.0.2 |

## How do I fix CVE-2026-115384?

Upgrade wasmtime to a fixed version for your release line: 48.0.4 or 49.0.2.

## Is CVE-2026-115384 being exploited?

There is no known exploitation of CVE-2026-115384 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115384 and fix it if it is affected.

What it is: CVE-2026-115384 is a critical vulnerability in bytecodealliance wasmtime, published on 22 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115384 in the wild and no public exploit code.

Affected packages and fixed versions:
- wasmtime (crates.io): affected from 39.0.0; fixed in 48.0.4, 49.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115384/ (Markdown: https://insights.sbomify.com/CVE-2026-115384/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115384
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115384
- OSV: https://osv.dev/vulnerability/CVE-2026-115384

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115384/
Summaries are generated and may contain mistakes; the official description above is the record.
