# CVE-2026-115385: Wasmtime 46.0.0 before 48.0.4 and 49.0.0 before 49.0.2 Host Panic via WASIp3 Timestamps


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** GHSA-c8j4-4v4r-vm84, GHSA-mr2v-56j5-cmfc, RUSTSEC-2026-0324, UBUNTU-CVE-2026-115385

## What is CVE-2026-115385?

CVE-2026-115385 is a medium-severity vulnerability in bytecodealliance wasmtime, published on 22 Oct 2026. 

### Official description

Wasmtime 46.0.0 before 48.0.4 and 49.0.0 before 49.0.2 contains a denial of service vulnerability in the wasmtime-wasi WASIp3 implementation that allows guests to abort the Unix host process. Guests with mutable preopened directory access can call set-times or set-times-at with negative seconds timestamps before the epoch, triggering an assertion failure that crashes the host.

Weakness: CWE-754 (Improper Check for Unusual or Exceptional Conditions)

## Which versions are affected by CVE-2026-115385?

1 open source package ship an affected version, including wasmtime-wasi.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wasmtime-wasi` | crates.io | From 46.0.0 | 48.0.4, 49.0.2 |

## How do I fix CVE-2026-115385?

Upgrade wasmtime-wasi to a fixed version for your release line: 48.0.4 or 49.0.2.

## Is CVE-2026-115385 being exploited?

There is no known exploitation of CVE-2026-115385 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115385 and fix it if it is affected.

What it is: CVE-2026-115385 is a medium-severity vulnerability in bytecodealliance wasmtime, published on 22 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115385 in the wild and no public exploit code.

Affected packages and fixed versions:
- wasmtime-wasi (crates.io): affected from 46.0.0; fixed in 48.0.4, 49.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115385/ (Markdown: https://insights.sbomify.com/CVE-2026-115385/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115385
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115385
- OSV: https://osv.dev/vulnerability/CVE-2026-115385

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115385/
Summaries are generated and may contain mistakes; the official description above is the record.
