# CVE-2026-115386: Wasmtime before 36.0.17, 37.0.0 before 48.0.4, and 49.0.0 before 49.0.2 Memory Disclosure via fd_readdir


- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-115386, GHSA-7vfm-vg2r-wpmh, GHSA-96f6-r43r-8c24, RUSTSEC-2026-0323, UBUNTU-CVE-2026-115386

## What is CVE-2026-115386?

CVE-2026-115386 is a low-severity vulnerability in bytecodealliance wasmtime, published on 22 Oct 2026. 

### Official description

Wasmtime before 36.0.17, 37.0.0 before 48.0.4, and 49.0.0 before 49.0.2 contains an information disclosure vulnerability in the WASIp1 fd_readdir implementation that copies uninitialized struct padding into guest memory. Guests with a preopened directory can list entries to receive three bytes of leftover host stack or heap memory per directory entry.

Weakness: CWE-908 (Use of Uninitialized Resource)

## Which versions are affected by CVE-2026-115386?

1 open source package ship an affected version, including wasmtime-wasi.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wasmtime-wasi` | crates.io | From 0.0.0-0 | 36.0.17, 48.0.4, 49.0.2 |

## How do I fix CVE-2026-115386?

Upgrade wasmtime-wasi to a fixed version for your release line: 36.0.17, 48.0.4 or 49.0.2.

## Is CVE-2026-115386 being exploited?

There is no known exploitation of CVE-2026-115386 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115386 and fix it if it is affected.

What it is: CVE-2026-115386 is a low-severity vulnerability in bytecodealliance wasmtime, published on 22 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115386 in the wild and no public exploit code.

Affected packages and fixed versions:
- wasmtime-wasi (crates.io): affected from 0.0.0-0; fixed in 36.0.17, 48.0.4, 49.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115386/ (Markdown: https://insights.sbomify.com/CVE-2026-115386/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115386
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115386
- OSV: https://osv.dev/vulnerability/CVE-2026-115386

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115386/
Summaries are generated and may contain mistakes; the official description above is the record.
