# CVE-2026-115388: wasmtime-wasi-http in Wasmtime before 36.0.16, 37.0.0 before 48.0.3, and 49.0.0 before 49.0.1 does not enforce the wasi:io/streams check-wri


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** GHSA-7qg7-h7wh-p6q8, GHSA-c9gc-w9vx-w86p, RUSTSEC-2026-0313, UBUNTU-CVE-2026-115388

## What is CVE-2026-115388?

CVE-2026-115388 is a medium-severity vulnerability in bytecodealliance wasmtime, published on 22 Oct 2026. 

### Official description

wasmtime-wasi-http in Wasmtime before 36.0.16, 37.0.0 before 48.0.3, and 49.0.0 before 49.0.1 does not enforce the wasi:io/streams check-write allowance for WASIp2 outgoing HTTP bodies, so oversized writes succeed instead of trapping. A malicious guest can pass large buffers to write on outgoing-body resources, holding host allocations for the store's lifetime and exhausting host memory.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-115388?

1 open source package ship an affected version, including wasmtime-wasi-http.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wasmtime-wasi-http` | crates.io | From 0.0.0-0 | 36.0.16, 48.0.3, 49.0.1 |

## How do I fix CVE-2026-115388?

Upgrade wasmtime-wasi-http to a fixed version for your release line: 36.0.16, 48.0.3 or 49.0.1.

## Is CVE-2026-115388 being exploited?

There is no known exploitation of CVE-2026-115388 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115388 and fix it if it is affected.

What it is: CVE-2026-115388 is a medium-severity vulnerability in bytecodealliance wasmtime, published on 22 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115388 in the wild and no public exploit code.

Affected packages and fixed versions:
- wasmtime-wasi-http (crates.io): affected from 0.0.0-0; fixed in 36.0.16, 48.0.3, 49.0.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115388/ (Markdown: https://insights.sbomify.com/CVE-2026-115388/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115388
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115388
- OSV: https://osv.dev/vulnerability/CVE-2026-115388

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115388/
Summaries are generated and may contain mistakes; the official description above is the record.
