# CVE-2026-115393: Wasmtime before 24.0.12, 25.0.0 before 36.0.13, 37.0.0 before 46.0.2, and 47.0.0 before 47.0.3 contains a type confusion vulnerability becau


- **Severity:** Low 1.0 (`CVSS:4.0/AV:L/AC:H/AT:P/PR:H/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-115393, GHSA-hgjw-h833-99q9, GHSA-hm3j-7f84-9x3r, RUSTSEC-2026-0222, UBUNTU-CVE-2026-115393

## What is CVE-2026-115393?

CVE-2026-115393 is a low-severity vulnerability in bytecodealliance wasmtime, published on 22 Oct 2026. 

### Official description

Wasmtime before 24.0.12, 25.0.0 before 36.0.13, 37.0.0 before 46.0.2, and 47.0.0 before 47.0.3 contains a type confusion vulnerability because several Store APIs fail to validate that objects belong to the Store's Engine. Embedders mixing objects between Engines via Instance::new, StructRefPre::new, or Tag::new can trigger trampoline signature mismatches causing out-of-bounds stack writes, GC heap corruption, or panics.

Weakness: CWE-787 (Out-of-bounds Write)

## Which versions are affected by CVE-2026-115393?

1 open source package ship an affected version, including wasmtime.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `wasmtime` | crates.io | From 0.0.0-0 | 24.0.12, 36.0.13, 46.0.2, 47.0.3 |

## How do I fix CVE-2026-115393?

Upgrade wasmtime to a fixed version for your release line: 24.0.12, 36.0.13, 46.0.2 or 47.0.3.

## Is CVE-2026-115393 being exploited?

There is no known exploitation of CVE-2026-115393 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115393 and fix it if it is affected.

What it is: CVE-2026-115393 is a low-severity vulnerability in bytecodealliance wasmtime, published on 22 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115393 in the wild and no public exploit code.

Affected packages and fixed versions:
- wasmtime (crates.io): affected from 0.0.0-0; fixed in 24.0.12, 36.0.13, 46.0.2, 47.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115393/ (Markdown: https://insights.sbomify.com/CVE-2026-115393/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115393
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115393
- OSV: https://osv.dev/vulnerability/CVE-2026-115393

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115393/
Summaries are generated and may contain mistakes; the official description above is the record.
