CVE-2026-115417 Memory allocation with excessive size value in the MQTT 3.1.1 compatibility adapter in aws-c-mqtt

High 8.2 Published Updated
Exploited in the wild
Not known
Fix
None listed

What is CVE-2026-115417?

CVE-2026-115417 is a high-severity vulnerability in aws-c-mqtt, published on 22 Oct 2026.

Official description

Memory allocation with excessive size value in the MQTT 3.1.1 compatibility adapter in AWS aws-c-mqtt before 0.16.2 might allow a remote actor to cause a denial of service of the client application.

To remediate this issue, users should upgrade to aws-c-mqtt 0.16.2 or later, or to an AWS Common Runtime or AWS IoT Device SDK release that bundles it.

Weakness: CWE-789

Which versions are affected by CVE-2026-115417?

How do I fix CVE-2026-115417?

No fix has been published for CVE-2026-115417 yet. Limit exposure of the affected software until one is available.

Is CVE-2026-115417 being exploited?

There is no known exploitation of CVE-2026-115417 in the wild and no public exploit code.

Sources

Also known as GHSA-g3x5-86mr-65p5.

Is CVE-2026-115417 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free