# CVE-2026-115418: SQL injection in the database-query custom resource handlers in the Amazon Web Services (AWS) Cloud Development Kit (CDK) @aws-cdk/aws-redsh


- **Severity:** High 7.0 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:L/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 26 Oct 2026
- **Updated:** 26 Oct 2026

## What is CVE-2026-115418?

CVE-2026-115418 is a high-severity vulnerability in aws-cdk/aws-redshift-alpha, published on 26 Oct 2026. 

### Official description

SQL injection in the database-query custom resource handlers in the Amazon Web Services (AWS) Cloud Development Kit (CDK) @aws-cdk/aws-redshift-alpha module before 2.274.0-alpha.0 could allow a third party who can influence construct property values to run SQL statements with Amazon Redshift superuser privileges, including granting access to all cluster users. The statements are reachable through crafted user names, comments, or passwords.

To remediate this issue, users should upgrade to version 2.274.0-alpha.0 or later and review existing table grants to PUBLIC.

Weakness: CWE-89 (Improper Neutralization of Special Elements used in an SQL Command)

## Which versions are affected by CVE-2026-115418?


## How do I fix CVE-2026-115418?

No fix has been published for CVE-2026-115418 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-115418 being exploited?

There is no known exploitation of CVE-2026-115418 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115418 and fix it if it is affected.

What it is: CVE-2026-115418 is a high-severity vulnerability in aws-cdk/aws-redshift-alpha, published on 26 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115418 in the wild and no public exploit code.

Affected product: aws-cdk/aws-redshift-alpha. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115418/ (Markdown: https://insights.sbomify.com/CVE-2026-115418/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115418
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115418
- OSV: https://osv.dev/vulnerability/CVE-2026-115418

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115418/
Summaries are generated and may contain mistakes; the official description above is the record.
