# CVE-2026-115419: Unintended disclosure of data element to wrong session in Strands Agents SDK A2A Server


- **Severity:** High 8.6 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 22 Oct 2026
- **Updated:** 22 Oct 2026
- **Also known as:** GHSA-4v6f-7vjh-6x4m

## What is CVE-2026-115419?

CVE-2026-115419 is a high-severity vulnerability in AWS strands-agents, published on 22 Oct 2026. 

### Official description

The A2A server component in Amazon Strands Agents SDK for Python before 1.43.0 and Amazon Strands Agents SDK for TypeScript before 1.5.0 does not properly isolate conversation state between callers. An authenticated remote user could read other tenants' conversation history and add persistent instructions that alter model behavior for subsequent callers via HTTP requests to the A2A endpoint using a different context_id.

To mitigate this issue, users should upgrade to strands-agents 1.43.0 (Python) or @strands-agents/sdk 1.5.0 (TypeScript).

Weakness: CWE-488 (Exposure of Data Element to Wrong Session)

## Which versions are affected by CVE-2026-115419?

4 open source packages ship an affected version, including strands-agents and @strands-agents/sdk.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `strands-agents` | PyPI | All versions | 1.43.0 |
| `strands-agents` | PyPI | All versions | 1.43.0 |
| `@strands-agents/sdk` | npm | All versions | 1.5.0 |
| `@strands-agents/sdk` | npm | All versions | 1.5.0 |

## How do I fix CVE-2026-115419?

Upgrade strands-agents to 1.43.0 or later.

## Is CVE-2026-115419 being exploited?

There is no known exploitation of CVE-2026-115419 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115419 and fix it if it is affected.

What it is: CVE-2026-115419 is a high-severity vulnerability in AWS strands-agents, published on 22 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115419 in the wild and no public exploit code.

Affected packages and fixed versions:
- strands-agents (PyPI): affected all versions; fixed in 1.43.0
- strands-agents (PyPI): affected all versions; fixed in 1.43.0
- @strands-agents/sdk (npm): affected all versions; fixed in 1.5.0
- @strands-agents/sdk (npm): affected all versions; fixed in 1.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115419/ (Markdown: https://insights.sbomify.com/CVE-2026-115419/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115419
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115419
- OSV: https://osv.dev/vulnerability/CVE-2026-115419

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115419/
Summaries are generated and may contain mistakes; the official description above is the record.
