# CVE-2026-115570: Electron: Mitigation for compromised eMudhra intermediate certificates


- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** GHSA-jr5w-w6x2-84p9

## What is CVE-2026-115570?

CVE-2026-115570 is a high-severity vulnerability in electron, published on 23 Oct 2026. 

### Official description

Electron is a framework for writing cross-platform desktop applications using JavaScript, HTML and CSS. Prior to 42.11.16, 43.8.1, 44.9.1, and 45.0.0-beta.6, Electron does not block compromised eMudhra intermediate certificates in Chromium networking, Node.js tls, Node.js https, or Node.js fetch. An attacker who holds a certificate issued through one of these intermediates and can intercept network traffic can impersonate a TLS server to an affected application. This issue is fixed in versions 42.11.16, 43.8.1, 44.9.1, and 45.0.0-beta.6.

Weakness: CWE-299 (Improper Check for Certificate Revocation)

## Which versions are affected by CVE-2026-115570?

8 open source packages ship an affected version, including electron.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `electron` | npm | All versions | 42.11.16 |
| `electron` | npm | All versions | 42.11.16 |
| `electron` | npm | From 43.0.0-alpha.1 | 43.8.1 |
| `electron` | npm | From 43.0.0-alpha.1 | 43.8.1 |
| `electron` | npm | From 44.0.0-alpha.1 | 44.9.1 |
| `electron` | npm | From 44.0.0-alpha.1 | 44.9.1 |
| `electron` | npm | From 45.0.0-alpha.1 | 45.0.0-beta.6 |
| `electron` | npm | From 45.0.0-alpha.1 | 45.0.0-beta.6 |

## How do I fix CVE-2026-115570?

Upgrade electron to a fixed version for your release line: 42.11.16, 43.8.1, 44.9.1 or 45.0.0-beta.6.

## Is CVE-2026-115570 being exploited?

There is no known exploitation of CVE-2026-115570 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115570 and fix it if it is affected.

What it is: CVE-2026-115570 is a high-severity vulnerability in electron, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115570 in the wild and no public exploit code.

Affected packages and fixed versions:
- electron (npm): affected all versions; fixed in 42.11.16
- electron (npm): affected all versions; fixed in 42.11.16
- electron (npm): affected from 43.0.0-alpha.1; fixed in 43.8.1
- electron (npm): affected from 43.0.0-alpha.1; fixed in 43.8.1
- electron (npm): affected from 44.0.0-alpha.1; fixed in 44.9.1
- electron (npm): affected from 44.0.0-alpha.1; fixed in 44.9.1
- electron (npm): affected from 45.0.0-alpha.1; fixed in 45.0.0-beta.6
- electron (npm): affected from 45.0.0-alpha.1; fixed in 45.0.0-beta.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115570/ (Markdown: https://insights.sbomify.com/CVE-2026-115570/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115570
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115570
- OSV: https://osv.dev/vulnerability/CVE-2026-115570

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115570/
Summaries are generated and may contain mistakes; the official description above is the record.
