# CVE-2026-115572: pypdf: Possible long runtimes for repeated references to the same missing object


- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 29 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-115572, ECHO-3dbe-66b2-4bc7, GHSA-6c7f-9265-g8fw, ROOT-APP-PYPI-CVE-2026-115572, UBUNTU-CVE-2026-115572

## What is CVE-2026-115572?

CVE-2026-115572 is a high-severity vulnerability in py-pdf pypdf, published on 23 Oct 2026. 

### Official description

pypdf is a free and open-source pure-python PDF library. Prior to 6.21.2, an attacker can craft a PDF that repeatedly references the same nonexistent indirect object, causing relevant file parts such as pages to trigger repeated full-file recovery loads and long runtimes when accessed. This issue is fixed in version 6.21.2.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-115572?

2 open source packages ship an affected version, including pypdf.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pypdf` | PyPI | All versions | 6.21.2 |
| `pypdf` | PyPI | All versions | 6.21.2 |

## How do I fix CVE-2026-115572?

Upgrade pypdf to 6.21.2 or later.

## Is CVE-2026-115572 being exploited?

There is no known exploitation of CVE-2026-115572 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115572 and fix it if it is affected.

What it is: CVE-2026-115572 is a high-severity vulnerability in py-pdf pypdf, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115572 in the wild and no public exploit code.

Affected packages and fixed versions:
- pypdf (PyPI): affected all versions; fixed in 6.21.2
- pypdf (PyPI): affected all versions; fixed in 6.21.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115572/ (Markdown: https://insights.sbomify.com/CVE-2026-115572/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115572
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115572
- OSV: https://osv.dev/vulnerability/CVE-2026-115572

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115572/
Summaries are generated and may contain mistakes; the official description above is the record.
