{"answers":{"affected":"3 open source packages ship an affected version, including virtualenv.","exploited":"There is no known exploitation of CVE-2026-115586 in the wild and no public exploit code.","fix":"Upgrade virtualenv to 21.14.13 or later.","what":"CVE-2026-115586 is a high-severity vulnerability in pypa virtualenv, published on 23 Oct 2026."},"fix_prompt":"Check this codebase for CVE-2026-115586 and fix it if it is affected.\n\nWhat it is: CVE-2026-115586 is a high-severity vulnerability in pypa virtualenv, published on 23 Oct 2026. \nExploitation: There is no known exploitation of CVE-2026-115586 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- virtualenv (Bitnami): affected from 21.14.9; fixed in 21.14.13\n- virtualenv (PyPI): affected from 21.14.9; fixed in 21.14.13\n- virtualenv (PyPI): affected from 21.14.9; fixed in 21.14.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-115586/ (Markdown: https://insights.sbomify.com/CVE-2026-115586/index.md)","id":"CVE-2026-115586","markdown":"https://insights.sbomify.com/CVE-2026-115586/index.md","name":"CVE-2026-115586","record":{"aliases":["BIT-virtualenv-2026-115586","ECHO-838c-3d75-21e8","GHSA-cx6f-vjhg-g3cc","UBUNTU-CVE-2026-115586"],"analysis":null,"analysis_generated_by":null,"assigner":"GitHub_M","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"virtualenv is a tool for creating isolated virtual python environments. From 21.14.9 until 21.14.13, the bash bin/activate script can copy an attacker-controlled --prompt value into PS1 without escaping dollar signs or backticks when both promptvars and POSIX mode are disabled during activation. Re-enabling promptvars, running set -o posix, or starting an interactive child bash that inherits the exported PS1 can then expand command substitution in the stored VIRTUAL_ENV_PROMPT value and execute commands as the user who activates the environment. This issue is fixed in version 21.14.13.","ecosystems":["Bitnami","PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"virtualenv: Bash activator leaves the --prompt value unescaped in PS1 when promptvars is off, so prompt expansion later executes it (regression in 21.14.9)","id":"CVE-2026-115586","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":null,"year":"2026"},"n_packages":3,"n_references":4,"next":{"headline":"WordPress Dokan plugin \u003c= 5.3.1 - PHP Object Injection vulnerability","id":"CVE-2026-115590"},"packages":[{"ecosystem":"Bitnami","fixed":["21.14.13"],"introduced":["21.14.9"],"last_affected":[],"package":"virtualenv","purl":"pkg:bitnami/virtualenv","source":"BIT-virtualenv-2026-115586"},{"ecosystem":"PyPI","fixed":["21.14.13"],"introduced":["21.14.9"],"last_affected":[],"package":"virtualenv","purl":null,"source":"GHSA-cx6f-vjhg-g3cc"},{"ecosystem":"PyPI","fixed":["21.14.13"],"introduced":["21.14.9"],"last_affected":[],"package":"virtualenv","purl":"pkg:pypi/virtualenv","source":"GHSA-cx6f-vjhg-g3cc"}],"prev":{"headline":"pypdf: Possible long runtimes for repeated malformed cross-reference entries (Follow-up)","id":"CVE-2026-115585"},"products":["virtualenv"],"published":"2026-10-23","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-10-23","vendors":["pypa"]},"summary":null,"url":"https://insights.sbomify.com/CVE-2026-115586/"}