# CVE-2026-115586: virtualenv: Bash activator leaves the --prompt value unescaped in PS1 when promptvars is off, so prompt expansion later executes it (regression in 21.14.9)


- **Severity:** High 7.1 (`CVSS:4.0/AV:L/AC:H/AT:P/PR:N/UI:A/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 23 Oct 2026
- **Updated:** 23 Oct 2026
- **Also known as:** BIT-virtualenv-2026-115586, ECHO-838c-3d75-21e8, GHSA-cx6f-vjhg-g3cc, UBUNTU-CVE-2026-115586

## What is CVE-2026-115586?

CVE-2026-115586 is a high-severity vulnerability in pypa virtualenv, published on 23 Oct 2026. 

### Official description

virtualenv is a tool for creating isolated virtual python environments. From 21.14.9 until 21.14.13, the bash bin/activate script can copy an attacker-controlled --prompt value into PS1 without escaping dollar signs or backticks when both promptvars and POSIX mode are disabled during activation. Re-enabling promptvars, running set -o posix, or starting an interactive child bash that inherits the exported PS1 can then expand command substitution in the stored VIRTUAL_ENV_PROMPT value and execute commands as the user who activates the environment. This issue is fixed in version 21.14.13.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-115586?

3 open source packages ship an affected version, including virtualenv.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `virtualenv` | Bitnami | From 21.14.9 | 21.14.13 |
| `virtualenv` | PyPI | From 21.14.9 | 21.14.13 |
| `virtualenv` | PyPI | From 21.14.9 | 21.14.13 |

## How do I fix CVE-2026-115586?

Upgrade virtualenv to 21.14.13 or later.

## Is CVE-2026-115586 being exploited?

There is no known exploitation of CVE-2026-115586 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115586 and fix it if it is affected.

What it is: CVE-2026-115586 is a high-severity vulnerability in pypa virtualenv, published on 23 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115586 in the wild and no public exploit code.

Affected packages and fixed versions:
- virtualenv (Bitnami): affected from 21.14.9; fixed in 21.14.13
- virtualenv (PyPI): affected from 21.14.9; fixed in 21.14.13
- virtualenv (PyPI): affected from 21.14.9; fixed in 21.14.13

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115586/ (Markdown: https://insights.sbomify.com/CVE-2026-115586/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115586
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115586
- OSV: https://osv.dev/vulnerability/CVE-2026-115586

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115586/
Summaries are generated and may contain mistakes; the official description above is the record.
