# CVE-2026-115627: Incorrect Authorization vulnerability in ash-project ash_postgres allows a user to load destination records linked to a source record only t


- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 25 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** EEF-CVE-2026-115627, GHSA-gr2r-f49c-9gm2

## What is CVE-2026-115627?

CVE-2026-115627 is a medium-severity vulnerability in ash-project ash_postgres, published on 25 Oct 2026. 

### Official description

Incorrect Authorization vulnerability in ash-project ash_postgres allows a user to load destination records linked to a source record only through another tenant's join rows.

When a many_to_many relationship, or a through relationship, is loaded with a lateral join (for example with a per-record limit or sort), AshPostgres.DataLayer builds the query for the join resource, and for each resource along a through path, in lateral_join_query/3 and through_step_queries/4 without running that resource's read action, which is where attribute multitenancy is applied. When those resources use strategy :attribute multitenancy, rows belonging to other tenants were joined, so the load returned destination records that the caller's tenant is not related to.

This issue affects ash_postgres: from 0.38.0 before 2.15.2.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-115627?

1 open source package ship an affected version, including ash_postgres.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash_postgres` | Hex | From 0.38.0 | 2.15.2 |

## How do I fix CVE-2026-115627?

Upgrade ash_postgres to 2.15.2 or later.

## Is CVE-2026-115627 being exploited?

There is no known exploitation of CVE-2026-115627 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115627 and fix it if it is affected.

What it is: CVE-2026-115627 is a medium-severity vulnerability in ash-project ash_postgres, published on 25 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115627 in the wild and no public exploit code.

Affected packages and fixed versions:
- ash_postgres (Hex): affected from 0.38.0; fixed in 2.15.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115627/ (Markdown: https://insights.sbomify.com/CVE-2026-115627/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115627
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115627
- OSV: https://osv.dev/vulnerability/CVE-2026-115627

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115627/
Summaries are generated and may contain mistakes; the official description above is the record.
