# CVE-2026-115693: Custom cacerts or cacertfile do not restrict trust to the pinned CA in hackney


- **Severity:** Critical 9.1 (`CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** EEF-CVE-2026-115693, GHSA-g7gg-9jhv-68h6

## What is CVE-2026-115693?

CVE-2026-115693 is a critical vulnerability in benoitc hackney, published on 26 Oct 2026. 

### Official description

Improper Certificate Validation vulnerability in hackney_ssl in benoitc hackney allows an on-path attacker to impersonate a server pinned to a private certificate authority via a certificate chain that ends in a publicly trusted root. hackney adds {partial_chain, fun hackney_ssl:partial_chain/1} to every verify_peer configuration. The callback returns any certificate in the peer chain whose public key matches a root in the bundled certifi store as the trust anchor, and OTP honours that callback over the configured cacerts. hackney_ssl:merge_ssl_opts/3 kept the callback when the caller replaced the trust store with cacerts or cacertfile in ssl_options, so a connection pinned to a private CA still accepted any chain that carried a publicly trusted root.

The hostname check still applies, so the attacker needs a publicly trusted certificate for the pinned hostname.

This issue affects hackney: from 1.24.0 before 4.9.0.

Weakness: CWE-295 (Improper Certificate Validation)

## Which versions are affected by CVE-2026-115693?

1 open source package ship an affected version, including hackney.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hackney` | Hex | From 1.24.0 | 4.9.0 |

## How do I fix CVE-2026-115693?

Upgrade hackney to 4.9.0 or later.

## Is CVE-2026-115693 being exploited?

There is no known exploitation of CVE-2026-115693 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115693 and fix it if it is affected.

What it is: CVE-2026-115693 is a critical vulnerability in benoitc hackney, published on 26 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115693 in the wild and no public exploit code.

Affected packages and fixed versions:
- hackney (Hex): affected from 1.24.0; fixed in 4.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115693/ (Markdown: https://insights.sbomify.com/CVE-2026-115693/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115693
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115693
- OSV: https://osv.dev/vulnerability/CVE-2026-115693

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115693/
Summaries are generated and may contain mistakes; the official description above is the record.
