# CVE-2026-115700: SSRF allowlist bypass via percent-encoded bracketed IPv6 or trailing-dot IP literal in hackney


- **Severity:** Medium 6.9 (`CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** EEF-CVE-2026-115700, GHSA-8c7g-m8h7-q24x

## What is CVE-2026-115700?

CVE-2026-115700 is a medium-severity vulnerability in benoitc hackney, published on 26 Oct 2026. 

### Official description

Interpretation Conflict vulnerability in hackney_url in benoitc hackney allows Server Side Request Forgery via a percent-encoded bracketed IPv6 literal or an IP literal with a trailing dot. A host such as %5B%3A%3Affff%3A127%2E0%2E0%2E1%5D (decoding to [::ffff:127.0.0.1]) or 127.0.0.1. is not an IP address to a caller's allowlist built on uri_string:parse/1 and inet:parse_address/1, while hackney connects to the address it denotes. The same applies to a Location target when redirects are followed.

The IP-literal gate that hackney_url:normalize/2 applies to a percent-decoded host, added to close the percent-encoded IP bypass of CVE-2026-47076, passes the decoded value to inet_parse:address/1 as is. The connect path in hackney_happy:parse_address/1 drops a surrounding bracket pair, and the resolver ignores a trailing dot, so both forms pass the gate and still reach the literal address. Domain names with a trailing dot and unencoded IPv6 literals are not affected.

This issue affects hackney: from 4.0.1 before 4.9.0.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2026-115700?

1 open source package ship an affected version, including hackney.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `hackney` | Hex | From 4.0.1 | 4.9.0 |

## How do I fix CVE-2026-115700?

Upgrade hackney to 4.9.0 or later.

## Is CVE-2026-115700 being exploited?

There is no known exploitation of CVE-2026-115700 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-115700 and fix it if it is affected.

What it is: CVE-2026-115700 is a medium-severity vulnerability in benoitc hackney, published on 26 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-115700 in the wild and no public exploit code.

Affected packages and fixed versions:
- hackney (Hex): affected from 4.0.1; fixed in 4.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-115700/ (Markdown: https://insights.sbomify.com/CVE-2026-115700/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-115700
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-115700
- OSV: https://osv.dev/vulnerability/CVE-2026-115700

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-115700/
Summaries are generated and may contain mistakes; the official description above is the record.
